aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/packagegroups
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-09-03 10:34:31 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-04 12:53:03 +0100
commit4a0bec427741946b7cf82d471508476a645930b9 (patch)
treea16192c3f39b48ca2d9755efb5f0cb894e996e75 /meta/recipes-graphics/packagegroups
parent5f0c2e3509d154a724367c2a5de274baeae08af8 (diff)
downloadopenembedded-core-contrib-4a0bec427741946b7cf82d471508476a645930b9.tar.gz
packagegroup-*: add RPROVIDES for backwards compatibility
Allow references to the old task packages to continue to work. This does not add RPROVIDES for everything, just those packages that are likely to have been referred to. (From OE-Core rev: b41c45972a6d359f034615471959c84aee2bc456) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/packagegroups')
-rw-r--r--meta/recipes-graphics/packagegroups/packagegroup-core-clutter.bb3
-rw-r--r--meta/recipes-graphics/packagegroups/packagegroup-core-gtk-directfb.bb3
-rw-r--r--meta/recipes-graphics/packagegroups/packagegroup-core-x11-base.bb3
3 files changed, 9 insertions, 0 deletions
diff --git a/meta/recipes-graphics/packagegroups/packagegroup-core-clutter.bb b/meta/recipes-graphics/packagegroups/packagegroup-core-clutter.bb
index 08dd09029c..37e9a877e1 100644
--- a/meta/recipes-graphics/packagegroups/packagegroup-core-clutter.bb
+++ b/meta/recipes-graphics/packagegroups/packagegroup-core-clutter.bb
@@ -13,6 +13,9 @@ PACKAGES = "\
${PN}-core \
"
+# For backwards compatibility after rename
+RPROVIDES_${PN}-core = "task-core-clutter-core"
+
SUMMARY_${PN}-core = "Clutter graphics library"
RDEPENDS_${PN}-core = "\
clutter-1.8 \
diff --git a/meta/recipes-graphics/packagegroups/packagegroup-core-gtk-directfb.bb b/meta/recipes-graphics/packagegroups/packagegroup-core-gtk-directfb.bb
index 6d92a38bc5..d6c29853eb 100644
--- a/meta/recipes-graphics/packagegroups/packagegroup-core-gtk-directfb.bb
+++ b/meta/recipes-graphics/packagegroups/packagegroup-core-gtk-directfb.bb
@@ -4,6 +4,9 @@ LICENSE = "MIT"
inherit packagegroup
+# For backwards compatibility after rename
+RPROVIDES_${PN} = "task-core-gtk-directfb-base"
+
TOUCH = ' ${@base_contains("MACHINE_FEATURES", "touchscreen", "tslib tslib-calibrate tslib-tests", "",d)}'
RDEPENDS_${PN} = " \
diff --git a/meta/recipes-graphics/packagegroups/packagegroup-core-x11-base.bb b/meta/recipes-graphics/packagegroups/packagegroup-core-x11-base.bb
index 75574c11e1..ebae741832 100644
--- a/meta/recipes-graphics/packagegroups/packagegroup-core-x11-base.bb
+++ b/meta/recipes-graphics/packagegroups/packagegroup-core-x11-base.bb
@@ -5,6 +5,9 @@ PR = "r0"
inherit packagegroup
+# For backwards compatibility after rename
+RPROVIDES_${PN} = "task-core-x11-mini task-core-x11-base"
+
RDEPENDS_${PN} = "\
packagegroup-core-x11-xserver \
packagegroup-core-x11-utils \