aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2012-11-08 11:31:31 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-11-12 12:44:42 +0000
commit1961ea1493caf5fe2959db2a11831a4a5a17eaeb (patch)
tree033da81a0cbb75e10928d0c1aa0ece7c03248276 /meta/recipes-graphics/mesa
parentb6d391903ae8baf902fa142a58533857ade6afd3 (diff)
downloadopenembedded-core-contrib-1961ea1493caf5fe2959db2a11831a4a5a17eaeb.tar.gz
mesa: remove python2 detection hack
Our python-native is 2.7.3 which ships python2, and we've been patching it in to earlier versions since September 2011. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/mesa')
-rw-r--r--meta/recipes-graphics/mesa/mesa-8.0.4.inc2
-rw-r--r--meta/recipes-graphics/mesa/mesa-dri_8.0.4.bb2
-rw-r--r--meta/recipes-graphics/mesa/mesa-dri_git.bb3
-rw-r--r--meta/recipes-graphics/mesa/mesa-git.inc2
4 files changed, 2 insertions, 7 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-8.0.4.inc b/meta/recipes-graphics/mesa/mesa-8.0.4.inc
index 9afb35dee6..c6307dc603 100644
--- a/meta/recipes-graphics/mesa/mesa-8.0.4.inc
+++ b/meta/recipes-graphics/mesa/mesa-8.0.4.inc
@@ -13,8 +13,6 @@ SRC_URI[md5sum] = "d546f988adfdf986cff45b1efa2d8a46"
SRC_URI[sha256sum] = "02ed19f4f5f6535dda03a9932a81438aa78ea723ebba1f39a3d49a70a4e1d07e"
do_configure_prepend() {
- #check for python not python2, because python-native does not stage python2 binary/link
- sed -i 's/AC_CHECK_PROGS(\[PYTHON2\], \[python2 python\])/AC_CHECK_PROGS(\[PYTHON2\], \[python python\])/g' ${S}/configure.ac
# We need builtin_compiler built for buildhost arch instead of target (is provided by mesa-dri-glsl-native)"
sed -i "s#\./builtin_compiler#${STAGING_BINDIR_NATIVE}/glsl/builtin_compiler#g" ${S}/src/glsl/Makefile
}
diff --git a/meta/recipes-graphics/mesa/mesa-dri_8.0.4.bb b/meta/recipes-graphics/mesa/mesa-dri_8.0.4.bb
index bd62c98ce4..fb356764bf 100644
--- a/meta/recipes-graphics/mesa/mesa-dri_8.0.4.bb
+++ b/meta/recipes-graphics/mesa/mesa-dri_8.0.4.bb
@@ -1,4 +1,4 @@
require mesa-common.inc
require mesa-${PV}.inc
require mesa-dri.inc
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
diff --git a/meta/recipes-graphics/mesa/mesa-dri_git.bb b/meta/recipes-graphics/mesa/mesa-dri_git.bb
index 4b36f20beb..de1aa14cc1 100644
--- a/meta/recipes-graphics/mesa/mesa-dri_git.bb
+++ b/meta/recipes-graphics/mesa/mesa-dri_git.bb
@@ -5,5 +5,4 @@ require mesa-dri.inc
# this needs to be lower than -1 because all mesa-dri have -1 and git version has highest PV, but shouldn't be default
DEFAULT_PREFERENCE = "-2"
-PR = "${INC_PR}.0"
-
+PR = "${INC_PR}.1"
diff --git a/meta/recipes-graphics/mesa/mesa-git.inc b/meta/recipes-graphics/mesa/mesa-git.inc
index 7910eb654d..b907931b7b 100644
--- a/meta/recipes-graphics/mesa/mesa-git.inc
+++ b/meta/recipes-graphics/mesa/mesa-git.inc
@@ -16,8 +16,6 @@ SRC_URI += "${@base_contains('DISTRO_FEATURES', 'x11', '', 'file://0004-gross-ha
S = "${WORKDIR}/git"
do_configure_prepend() {
- #check for python not python2, because python-native does not stage python2 binary/link
- sed -i 's/AC_CHECK_PROGS(\[PYTHON2\], \[python2 python\])/AC_CHECK_PROGS(\[PYTHON2\], \[python python\])/g' ${S}/configure.ac
# We need builtin_compiler built for buildhost arch instead of target (is provided by mesa-dri-glsl-native)"
sed -i "s#\./builtin_compiler#${STAGING_BINDIR_NATIVE}/glsl/builtin_compiler#g" ${S}/src/glsl/Makefile
}