aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2013-07-01 21:36:25 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-07-05 15:26:21 +0100
commit0cc7f4ebad7f4390ac340854b57111d5084bd956 (patch)
treed43106f8d6acf6ea1ae65c37d98e394d7ed5a249 /meta/recipes-graphics/mesa
parent0b1e64a8d026a8021f4568758a637689e886037b (diff)
downloadopenembedded-core-contrib-0cc7f4ebad7f4390ac340854b57111d5084bd956.tar.gz
mesa: fix pipe_loader_sw build without libx11
* this is needed to fix pipe_loader_sw build without libx11, but building with HAVE_PIPE_LOADER_XLIB enabled still doesn't work (nobody is using this and it was removed in newer SRCREV). See https://bugs.freedesktop.org/show_bug.cgi?id=66357 for details. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-graphics/mesa')
-rw-r--r--meta/recipes-graphics/mesa/mesa/0002-pipe_loader_sw-include-xlib_sw_winsys.h-only-when-HA.patch52
-rw-r--r--meta/recipes-graphics/mesa/mesa_9.1.3.bb1
-rw-r--r--meta/recipes-graphics/mesa/mesa_git.bb1
3 files changed, 54 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa/0002-pipe_loader_sw-include-xlib_sw_winsys.h-only-when-HA.patch b/meta/recipes-graphics/mesa/mesa/0002-pipe_loader_sw-include-xlib_sw_winsys.h-only-when-HA.patch
new file mode 100644
index 0000000000..2df5e61d21
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa/0002-pipe_loader_sw-include-xlib_sw_winsys.h-only-when-HA.patch
@@ -0,0 +1,52 @@
+From debac5531f7107d239530ff6e29eeda72b9ec1e9 Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Sat, 29 Jun 2013 11:20:51 +0200
+Subject: [PATCH 2/4] pipe_loader_sw: include xlib_sw_winsys.h only when
+ HAVE_PIPE_LOADER_XLIB
+
+* HAVE_WINSYS_XLIB was removed in
+ commit b3f1f665b0fef178ae193e6b111f14c9a5ad3b25
+ Author: Matt Turner <mattst88@gmail.com>
+ Date: Sun Jan 20 15:32:08 2013 -0800
+ build: Get rid of GALLIUM_WINSYS_DIRS
+
+* HAVE_PIPE_LOADER_XLIB is set correctly:
+ if test "x$NEED_WINSYS_XLIB" = xyes; then
+ GALLIUM_PIPE_LOADER_DEFINES="$GALLIUM_PIPE_LOADER_DEFINES -DHAVE_PIPE_LOADER_XLIB"
+ GALLIUM_PIPE_LOADER_LIBS="$GALLIUM_PIPE_LOADER_LIBS \$(top_builddir)/src/gallium/winsys/sw/xlib/libws_xlib.la"
+ fi
+
+* fixes build of pipe_loader_sw without libx11 headers available
+
+Upstream-Status: Submitted https://bugs.freedesktop.org/show_bug.cgi?id=66357
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+---
+ src/gallium/auxiliary/pipe-loader/pipe_loader_sw.c | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/src/gallium/auxiliary/pipe-loader/pipe_loader_sw.c b/src/gallium/auxiliary/pipe-loader/pipe_loader_sw.c
+index c2b78c6..0da3f4d 100644
+--- a/src/gallium/auxiliary/pipe-loader/pipe_loader_sw.c
++++ b/src/gallium/auxiliary/pipe-loader/pipe_loader_sw.c
+@@ -31,7 +31,9 @@
+ #include "util/u_dl.h"
+ #include "sw/null/null_sw_winsys.h"
+ #include "target-helpers/inline_sw_helper.h"
++#ifdef HAVE_PIPE_LOADER_XLIB
+ #include "state_tracker/xlib_sw_winsys.h"
++#endif
+
+ struct pipe_loader_sw_device {
+ struct pipe_loader_device base;
+@@ -44,7 +46,7 @@ struct pipe_loader_sw_device {
+ static struct pipe_loader_ops pipe_loader_sw_ops;
+
+ static struct sw_winsys *(*backends[])() = {
+-#ifdef HAVE_WINSYS_XLIB
++#ifdef HAVE_PIPE_LOADER_XLIB
+ x11_sw_create,
+ #endif
+ null_sw_create
+--
+1.8.2.1
+
diff --git a/meta/recipes-graphics/mesa/mesa_9.1.3.bb b/meta/recipes-graphics/mesa/mesa_9.1.3.bb
index ec95c10e14..bbeacd388e 100644
--- a/meta/recipes-graphics/mesa/mesa_9.1.3.bb
+++ b/meta/recipes-graphics/mesa/mesa_9.1.3.bb
@@ -5,6 +5,7 @@ SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2 \
file://fix-glsl-cross.patch \
file://0001-configure-Avoid-use-of-AC_CHECK_FILE-for-cross-compi.patch \
file://0001-llvmpipe-remove-the-power-of-two-sizeof-struct-cmd_b.patch \
+ file://0002-pipe_loader_sw-include-xlib_sw_winsys.h-only-when-HA.patch \
"
SRC_URI[md5sum] = "952ccd03547ed72333b64e1746cf8ada"
diff --git a/meta/recipes-graphics/mesa/mesa_git.bb b/meta/recipes-graphics/mesa/mesa_git.bb
index 5e252affa1..09a9531227 100644
--- a/meta/recipes-graphics/mesa/mesa_git.bb
+++ b/meta/recipes-graphics/mesa/mesa_git.bb
@@ -12,6 +12,7 @@ SRC_URI = "git://anongit.freedesktop.org/git/mesa/mesa;protocol=git \
file://fix-glsl-cross.patch \
file://0001-configure-Avoid-use-of-AC_CHECK_FILE-for-cross-compi.patch \
file://0001-llvmpipe-remove-the-power-of-two-sizeof-struct-cmd_b.patch \
+ file://0002-pipe_loader_sw-include-xlib_sw_winsys.h-only-when-HA.patch \
"
S = "${WORKDIR}/git"