aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa.inc
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2013-10-21 14:30:37 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-10-26 15:53:24 +0100
commit981f7e5b088ecd813e43291d72f8995f17dbea8e (patch)
treebd433068931fb29f42edee9cdb7fa6b35655dc36 /meta/recipes-graphics/mesa/mesa.inc
parent8d872e7712a62fa4313a1114a92907c29beffa2e (diff)
downloadopenembedded-core-contrib-981f7e5b088ecd813e43291d72f8995f17dbea8e.tar.gz
mesa: fix dependency
libudev is asked by enable-gbm, not enable_dri, and enable-gbm always is yes; We can find the dependency from configure.ac codes: if test "x$enable_gbm" = xyes; then SRC_DIRS="$SRC_DIRS gbm" PKG_CHECK_MODULES([LIBUDEV], [libudev], [], AC_MSG_ERROR([gbm needs udev])) if test "x$enable_dri" = xyes; then GBM_BACKEND_DIRS="$GBM_BACKEND_DIRS dri" if test "x$enable_shared_glapi" = xno; then AC_MSG_ERROR([gbm_dri requires --enable-shared-glapi]) fi fi fi Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa.inc')
-rw-r--r--meta/recipes-graphics/mesa/mesa.inc4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-graphics/mesa/mesa.inc b/meta/recipes-graphics/mesa/mesa.inc
index 3e8041b463..2b66582c19 100644
--- a/meta/recipes-graphics/mesa/mesa.inc
+++ b/meta/recipes-graphics/mesa/mesa.inc
@@ -15,7 +15,7 @@ LIC_FILES_CHKSUM = "file://docs/license.html;md5=42d77d95cba529a3637129be87d6555
INC_PR = "r9"
PE = "2"
-DEPENDS = "expat makedepend-native flex-native bison-native"
+DEPENDS = "expat makedepend-native flex-native bison-native udev"
PROVIDES = "virtual/libgl virtual/libgles1 virtual/libgles2 virtual/egl virtual/mesa"
@@ -38,7 +38,7 @@ PACKAGECONFIG[wayland] = ",,wayland"
DRIDRIVERS = "swrast"
DRIDRIVERS_append_x86 = ",radeon,r200,nouveau,i965,i915"
DRIDRIVERS_append_x86-64 = ",radeon,r200,nouveau,i965,i915"
-PACKAGECONFIG[dri] = "--enable-dri --with-dri-drivers=${DRIDRIVERS}, --disable-dri, dri2proto libdrm udev"
+PACKAGECONFIG[dri] = "--enable-dri --with-dri-drivers=${DRIDRIVERS}, --disable-dri, dri2proto libdrm"
EXTRA_OECONF += "--enable-gbm"