aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa.inc
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2013-06-13 01:19:55 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-14 12:40:52 +0100
commit50dcfeab2b18422f3ab067893a0b68b17706d6e2 (patch)
tree07e851cd75bb073172fcf997fdf7d97928e71c97 /meta/recipes-graphics/mesa/mesa.inc
parentf780ec28cbaade55361390a04ac70574bde426de (diff)
downloadopenembedded-core-contrib-50dcfeab2b18422f3ab067893a0b68b17706d6e2.tar.gz
mesa: use PACKAGECONFIG instead of DISTRO_FEATURES to define EGL_PLATFORMS
* it makes it easier to change PACKAGECONFIG in .bbappend and get consistent EGL_PLATFORMS Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa.inc')
-rw-r--r--meta/recipes-graphics/mesa/mesa.inc4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-graphics/mesa/mesa.inc b/meta/recipes-graphics/mesa/mesa.inc
index ec30301840..cc117531c7 100644
--- a/meta/recipes-graphics/mesa/mesa.inc
+++ b/meta/recipes-graphics/mesa/mesa.inc
@@ -42,8 +42,8 @@ EXTRA_OECONF += "--enable-gbm"
PACKAGECONFIG[gles] = "--enable-gles1 --enable-gles2, --disable-gles1 --disable-gles2"
EGL_PLATFORMS = "drm"
-EGL_PLATFORMS .="${@base_contains('DISTRO_FEATURES', 'x11', ',x11', '', d)}"
-EGL_PLATFORMS .="${@base_contains('DISTRO_FEATURES', 'wayland', ',wayland', '', d)}"
+EGL_PLATFORMS .="${@base_contains('PACKAGECONFIG', 'x11', ',x11', '', d)}"
+EGL_PLATFORMS .="${@base_contains('PACKAGECONFIG', 'wayland', ',wayland', '', d)}"
PACKAGECONFIG[egl] = "--enable-egl --with-egl-platforms=${EGL_PLATFORMS}, --disable-egl"
# Multiple virtual/gl providers being built breaks staging