aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa-demos
diff options
context:
space:
mode:
authorDrew Moseley <drew_moseley@mentor.com>2014-11-26 19:49:55 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-05 17:42:46 +0000
commit9e4b25893cc8e15e390b8f25545416ef431f0b88 (patch)
tree6d00e81444477d7c8ebf16e3718c3a7f81d4a269 /meta/recipes-graphics/mesa/mesa-demos
parent9245cb4fe211da06283d53086bca3fcd5b2c8aef (diff)
downloadopenembedded-core-contrib-9e4b25893cc8e15e390b8f25545416ef431f0b88.tar.gz
mesa-demos: Move util to the front of the SUBDIRS variable.
This forces it to be built first since many of the demos require it. Resolves build failures such as the following when certain demos are enabled (notably when PACKAGECONFIG contains glut): make[2]: *** No rule to make target `../util/libutil.la', needed by `copypix'. Stop. Signed-off-by: Drew Moseley <drew_moseley@mentor.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa-demos')
-rw-r--r--meta/recipes-graphics/mesa/mesa-demos/0003-configure-Allow-to-disable-demos-which-require-GLEW-.patch10
1 files changed, 7 insertions, 3 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-demos/0003-configure-Allow-to-disable-demos-which-require-GLEW-.patch b/meta/recipes-graphics/mesa/mesa-demos/0003-configure-Allow-to-disable-demos-which-require-GLEW-.patch
index e02f1ab4ec..4b07193a7f 100644
--- a/meta/recipes-graphics/mesa/mesa-demos/0003-configure-Allow-to-disable-demos-which-require-GLEW-.patch
+++ b/meta/recipes-graphics/mesa/mesa-demos/0003-configure-Allow-to-disable-demos-which-require-GLEW-.patch
@@ -95,11 +95,16 @@ diff --git a/src/Makefile.am b/src/Makefile.am
index 1647d64..754c47c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
-@@ -23,14 +23,13 @@
+@@ -23,14 +23,18 @@
# Eric Anholt <eric@anholt.net>
++if HAVE_GLEW
++UTIL = util
++endif
++
SUBDIRS = \
- util \
++ $(UTIL) \
data \
demos \
egl \
@@ -111,7 +116,7 @@ index 1647d64..754c47c 100644
objviewer \
osdemos \
perf \
-@@ -40,8 +39,13 @@ SUBDIRS = \
+@@ -40,8 +39,12 @@ SUBDIRS = \
slang \
tests \
tools \
@@ -125,7 +130,6 @@ index 1647d64..754c47c 100644
+SUBDIRS += \
+ vp \
+ vpglsl \
-+ util \
+ trivial
+endif
diff --git a/src/demos/Makefile.am b/src/demos/Makefile.am