aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa-demos
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2012-11-12 15:03:28 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-11-12 22:32:08 +0000
commit7e1e3066e37a458b21294e1f5cfc3ed96efd5c7c (patch)
tree5b4d2e1de37fdc633e99e9e9765b14f09e9b9f20 /meta/recipes-graphics/mesa/mesa-demos
parentfe16cbc6ed42c8764ac25417b72668d55f573e86 (diff)
downloadopenembedded-core-contrib-7e1e3066e37a458b21294e1f5cfc3ed96efd5c7c.tar.gz
mesa-demos: fix --with-glut check
The GLUT check was automatic and couldn't be disabled, so mesa-demos would gain a GLUT dependency if it was present when built. So, fix configure.ac so that --without-glut works as expected. (From OE-Core rev: fa7fb44d1ca2b8a57509806bde19672c68ef157d) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa-demos')
-rw-r--r--meta/recipes-graphics/mesa/mesa-demos/glut.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-demos/glut.patch b/meta/recipes-graphics/mesa/mesa-demos/glut.patch
new file mode 100644
index 0000000000..84b6d4f7f3
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa-demos/glut.patch
@@ -0,0 +1,46 @@
+Correctly implement with AC_WITH(glut) so that --without-glut works.
+
+Upstream-Status: Submitted [https://bugs.freedesktop.org/show_bug.cgi?id=57013]
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+Index: mesa-demos-8.0.1/configure.ac
+===================================================================
+--- mesa-demos-8.0.1.orig/configure.ac 2010-07-13 19:52:41.000000000 +0100
++++ mesa-demos-8.0.1/configure.ac 2012-11-12 12:49:54.940054571 +0000
+@@ -65,21 +65,25 @@
+ DEMO_LIBS="$DEMO_LIBS $GL_LIBS"
+
+ dnl Check for GLUT
+-GLUT_CFLAGS=""
+-GLUT_LIBS=-lglut
+-glut_enabled=yes
++glut_enabled=no
+ AC_ARG_WITH([glut],
+ [AS_HELP_STRING([--with-glut=DIR],
+ [glut install directory])],
+ [GLUT_CFLAGS="-I$withval/include"
+- GLUT_LIBS="-L$withval/lib -lglut"])
+-AC_CHECK_HEADER([GL/glut.h],
+- [],
+- [glut_enabled=no])
+-AC_CHECK_LIB([glut],
+- [glutInit],
+- [],
+- [glut_enabled=no])
++ GLUT_LIBS="-L$withval/lib -lglut"],
++ [GLUT_CFLAGS=""
++ GLUT_LIBS="-lglut"]
++ )
++AS_IF([test "x$with_glut" != xno],
++ [AC_CHECK_HEADER([GL/glut.h],
++ [],
++ [glut_enabled=no])
++ AC_CHECK_LIB([glut],
++ [glutInit],
++ [],
++ [glut_enabled=no])
++ glut_enabled=yes
++])
+
+ GLEW_CFLAGS=""
+ GLEW_LIBS="-lGLEW"