aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/libglu_9.0.0.bb
diff options
context:
space:
mode:
authorDaniel Stone <daniel@fooishbar.org>2012-10-26 16:00:09 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-11-02 16:15:28 +0000
commit4395691a44b198ba0b9a969cbade669e8de07a4f (patch)
tree9f6508512046e0cf7dcf3c6d69ae855a5b5bd9ec /meta/recipes-graphics/mesa/libglu_9.0.0.bb
parentf2dfc50bdf403719d40d04488245fd37655b5480 (diff)
downloadopenembedded-core-contrib-4395691a44b198ba0b9a969cbade669e8de07a4f.tar.gz
mesa: Build separate GLU library
Mesa has removed GLU from the core tree upstream, so remove it from the Mesa build and add the separate tarball as a new recipe. Signed-off-by: Daniel Stone <daniel@fooishbar.org> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/mesa/libglu_9.0.0.bb')
-rw-r--r--meta/recipes-graphics/mesa/libglu_9.0.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/libglu_9.0.0.bb b/meta/recipes-graphics/mesa/libglu_9.0.0.bb
new file mode 100644
index 0000000000..79807491bd
--- /dev/null
+++ b/meta/recipes-graphics/mesa/libglu_9.0.0.bb
@@ -0,0 +1,27 @@
+SUMMARY = "The OpenGL utility toolkit"
+DESCRIPTION = "GLU is a utility toolkit used with OpenGL implementations"
+
+HOMEPAGE = "http://mesa3d.org"
+BUGTRACKER = "https://bugs.freedesktop.org"
+SECTION = "x11"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://include/GL/glu.h;endline=29;md5=6b79c570f644363b356456e7d44471d9 \
+ file://src/libtess/tess.c;endline=29;md5=6b79c570f644363b356456e7d44471d9"
+
+# Epoch as this used to be part of mesa-dri
+PE = "2"
+PR = "0"
+
+SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/glu/glu-${PV}.tar.bz2"
+
+SRC_URI[md5sum] = "be9249132ff49275461cf92039083030"
+SRC_URI[sha256sum] = "1f7ad0d379a722fcbd303aa5650c6d7d5544fde83196b42a73d1193568a4df12"
+
+S = "${WORKDIR}/glu-${PV}"
+
+DEPENDS = "virtual/libgl"
+
+inherit autotools pkgconfig
+
+# Remove the mesa-glu dependency in mesa-glu-dev, as mesa-glu is empty
+RDEPENDS_${PN}-dev = ""