aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/files
diff options
context:
space:
mode:
authorNicolas Dechesne <nicolas.dechesne@linaro.org>2017-06-01 12:29:45 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-03 23:45:51 +0100
commitfa08267f1399904fed079277bc86ac1aa26c06dc (patch)
tree21c8e4ea62fa51e6dde7cefb4fb7a1a743b1364b /meta/recipes-graphics/mesa/files
parent803d74a42568a4b5afe8a15021cccc9455c8c8a0 (diff)
downloadopenembedded-core-contrib-fa08267f1399904fed079277bc86ac1aa26c06dc.tar.gz
mesa: upgrade to 17.1.1
* Costmetic changes in license.html file required new MD5 hash * Add PACKAGECONFIG option for libunwind support (new feature, disable by default) * Rebased 0001-Use-wayland-scanner-in-the-path.patch * Added zlib in DEPENDS, otherwise mesa no longer builds. * Added 0001-util-rand_xor-add-missing-include-statements.patch, sent upstream Signed-off-by: Nicolas Dechesne <nicolas.dechesne@linaro.org> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics/mesa/files')
-rw-r--r--meta/recipes-graphics/mesa/files/0001-Use-wayland-scanner-in-the-path.patch12
-rw-r--r--meta/recipes-graphics/mesa/files/0001-util-rand_xor-add-missing-include-statements.patch35
2 files changed, 41 insertions, 6 deletions
diff --git a/meta/recipes-graphics/mesa/files/0001-Use-wayland-scanner-in-the-path.patch b/meta/recipes-graphics/mesa/files/0001-Use-wayland-scanner-in-the-path.patch
index e49695bf85..eb6ff4ff04 100644
--- a/meta/recipes-graphics/mesa/files/0001-Use-wayland-scanner-in-the-path.patch
+++ b/meta/recipes-graphics/mesa/files/0001-Use-wayland-scanner-in-the-path.patch
@@ -1,4 +1,4 @@
-From 2f68fcaaf4964e7feeb383f5c26851965cda037c Mon Sep 17 00:00:00 2001
+From c908f0c13ac81a3a52140f129a13b2bc997ff4ee Mon Sep 17 00:00:00 2001
From: Jussi Kukkonen <jussi.kukkonen@intel.com>
Date: Tue, 15 Nov 2016 15:20:49 +0200
Subject: [PATCH] Simplify wayland-scanner lookup
@@ -15,23 +15,23 @@ Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
1 file changed, 1 insertion(+), 6 deletions(-)
diff --git a/configure.ac b/configure.ac
-index e56e35a..a92005a 100644
+index 2c7e636fac..d2b2350739 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -2020,12 +2020,7 @@ if test "x$with_egl_platforms" != "x" -a "x$enable_egl" != xyes; then
- AC_MSG_ERROR([cannot build egl state tracker without EGL library])
+@@ -2174,12 +2174,7 @@ if test "x$with_platforms" != xauto; then
+ with_egl_platforms=$with_platforms
fi
-PKG_CHECK_MODULES([WAYLAND_SCANNER], [wayland-scanner],
- WAYLAND_SCANNER=`$PKG_CONFIG --variable=wayland_scanner wayland-scanner`,
- WAYLAND_SCANNER='')
-if test "x$WAYLAND_SCANNER" = x; then
-- AC_PATH_PROG([WAYLAND_SCANNER], [wayland-scanner])
+- AC_PATH_PROG([WAYLAND_SCANNER], [wayland-scanner], [:])
-fi
+AC_PATH_PROG([WAYLAND_SCANNER], [wayland-scanner])
# Do per-EGL platform setups and checks
egl_platforms=`IFS=', '; echo $with_egl_platforms`
--
-2.1.4
+2.13.0
diff --git a/meta/recipes-graphics/mesa/files/0001-util-rand_xor-add-missing-include-statements.patch b/meta/recipes-graphics/mesa/files/0001-util-rand_xor-add-missing-include-statements.patch
new file mode 100644
index 0000000000..ffe8b96163
--- /dev/null
+++ b/meta/recipes-graphics/mesa/files/0001-util-rand_xor-add-missing-include-statements.patch
@@ -0,0 +1,35 @@
+From a8a1081ec05634e667d6670ab7c128d536cc60a9 Mon Sep 17 00:00:00 2001
+From: Nicolas Dechesne <nicolas.dechesne@linaro.org>
+Date: Thu, 1 Jun 2017 11:59:42 +0200
+Subject: [PATCH] util/rand_xor: add missing include statements
+
+Fixes for:
+
+src/util/rand_xor.c:60:13: error: implicit declaration of function 'open' [-Werror=implicit-function-declaration]
+ int fd = open("/dev/urandom", O_RDONLY);
+ ^~~~
+src/util/rand_xor.c:60:34: error: 'O_RDONLY' undeclared (first use in this function)
+ int fd = open("/dev/urandom", O_RDONLY);
+ ^~~~~~~~
+
+Upstream-Status: Submitted [ https://lists.freedesktop.org/archives/mesa-dev/2017-June/157542.html ]
+Signed-off-by: Nicolas Dechesne <nicolas.dechesne@linaro.org>
+---
+ src/util/rand_xor.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/util/rand_xor.c b/src/util/rand_xor.c
+index de05fa64b3..de04bbc284 100644
+--- a/src/util/rand_xor.c
++++ b/src/util/rand_xor.c
+@@ -25,6 +25,7 @@
+ #if defined(__linux__)
+ #include <sys/file.h>
+ #include <unistd.h>
++#include <fcntl.h>
+ #else
+ #include <time.h>
+ #endif
+--
+2.13.0
+