aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/files/0008-egl-fix-build-race-in-automake.patch
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2018-06-29 18:01:41 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-02 09:35:02 +0100
commit4acdeb1529f5355b2849556e9f4ef302e35d3b0c (patch)
treeb865c048d1c2493ed4495c08c889426f305e7a09 /meta/recipes-graphics/mesa/files/0008-egl-fix-build-race-in-automake.patch
parentbe6ef728fd36049ea3822a54909a995bdecf6dd0 (diff)
downloadopenembedded-core-contrib-4acdeb1529f5355b2849556e9f4ef302e35d3b0c.tar.gz
mesa: Upgrade 18.1.2 -> 18.1.3
This upgrades mesa to the 18.1.3 stable release. The changes can be found at: https://www.mesa3d.org/relnotes/18.1.3.html Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/mesa/files/0008-egl-fix-build-race-in-automake.patch')
-rw-r--r--meta/recipes-graphics/mesa/files/0008-egl-fix-build-race-in-automake.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/files/0008-egl-fix-build-race-in-automake.patch b/meta/recipes-graphics/mesa/files/0008-egl-fix-build-race-in-automake.patch
new file mode 100644
index 0000000000..f594233206
--- /dev/null
+++ b/meta/recipes-graphics/mesa/files/0008-egl-fix-build-race-in-automake.patch
@@ -0,0 +1,41 @@
+From b2aae4b8c6661424c1809d3e7b43f266e35385a6 Mon Sep 17 00:00:00 2001
+From: Ross Burton <ross.burton@intel.com>
+Date: Thu, 28 Jun 2018 23:01:59 +0100
+Subject: [PATCH 8/8] egl: fix build race in automake
+Organization: O.S. Systems Software LTDA.
+
+There is a parallel make build issue in src/egl/drivers/dri2/
+for wayland builds. Can be reproduced with:
+
+$ rm src/egl/drivers/dri2/*.h src/egl/drivers/dri2/platform_wayland.lo
+$ make -C src/egl/ drivers/dri2/platform_wayland.lo
+../../../mesa-18.1.2/src/egl/drivers/dri2/platform_wayland.c:50:10: fatal error: linux-dmabuf-unstable-v1-client-protocol.h: No such file or directory
+
+This patch adds the missing dependency.
+
+Fixes: 02cc359372773800de817 "egl/wayland: Use linux-dmabuf interface for buffers"
+Reviewed-by: Eric Engestrom <eric.engestrom@intel.com>
+
+Upstream-Status: Backport [18.2.0]
+
+[Eric: fixed up the commit title]
+Signed-off-by: Eric Engestrom <eric.engestrom@intel.com>
+---
+ src/egl/Makefile.am | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/egl/Makefile.am b/src/egl/Makefile.am
+index 086a4a1e63..116ed4ebf5 100644
+--- a/src/egl/Makefile.am
++++ b/src/egl/Makefile.am
+@@ -80,6 +80,7 @@ drivers/dri2/linux-dmabuf-unstable-v1-client-protocol.h: $(WL_DMABUF_XML)
+ if HAVE_PLATFORM_WAYLAND
+ drivers/dri2/linux-dmabuf-unstable-v1-protocol.lo: drivers/dri2/linux-dmabuf-unstable-v1-client-protocol.h
+ drivers/dri2/egl_dri2.lo: drivers/dri2/linux-dmabuf-unstable-v1-client-protocol.h
++drivers/dri2/platform_wayland.lo: drivers/dri2/linux-dmabuf-unstable-v1-client-protocol.h
+
+ AM_CFLAGS += $(WAYLAND_CLIENT_CFLAGS)
+ libEGL_common_la_LIBADD += $(WAYLAND_CLIENT_LIBS)
+--
+2.18.0
+