aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/files/0002-Simplify-wayland-scanner-lookup.patch
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2018-06-06 10:45:48 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-06-18 10:59:33 +0100
commit8803a6e31a4b64eb9d3c146567375c98972074df (patch)
treec38ebb221d954342035b449a93fd254f6d9d272c /meta/recipes-graphics/mesa/files/0002-Simplify-wayland-scanner-lookup.patch
parent322e41de7f4fb21315bf75f1038314c31ac4754b (diff)
downloadopenembedded-core-contrib-8803a6e31a4b64eb9d3c146567375c98972074df.tar.gz
mesa: Update 18.0.2 -> 18.1.1
This includes all bugfixes of 18.0.x series and major new features. For list of changes check: https://www.mesa3d.org/relnotes/18.1.0.html https://www.mesa3d.org/relnotes/18.1.1.html Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/mesa/files/0002-Simplify-wayland-scanner-lookup.patch')
-rw-r--r--meta/recipes-graphics/mesa/files/0002-Simplify-wayland-scanner-lookup.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/files/0002-Simplify-wayland-scanner-lookup.patch b/meta/recipes-graphics/mesa/files/0002-Simplify-wayland-scanner-lookup.patch
new file mode 100644
index 0000000000..e7585060ac
--- /dev/null
+++ b/meta/recipes-graphics/mesa/files/0002-Simplify-wayland-scanner-lookup.patch
@@ -0,0 +1,38 @@
+From 135f6ae990df9abe3765ed339f76c55026c86fe5 Mon Sep 17 00:00:00 2001
+From: Jussi Kukkonen <jussi.kukkonen@intel.com>
+Date: Tue, 15 Nov 2016 15:20:49 +0200
+Subject: [PATCH 2/7] Simplify wayland-scanner lookup
+Organization: O.S. Systems Software LTDA.
+
+Don't use pkg-config to lookup the path of a binary that's in the path.
+
+Alternatively we'd have to prefix the path returned by pkg-config with
+PKG_CONFIG_SYSROOT_DIR.
+
+Upstream-Status: Pending
+Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
+---
+ configure.ac | 7 +------
+ 1 file changed, 1 insertion(+), 6 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index f1fbdcc6c7..7c95598afc 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1796,12 +1796,7 @@ for plat in $platforms; do
+ PKG_CHECK_MODULES([WAYLAND_PROTOCOLS], [wayland-protocols >= $WAYLAND_PROTOCOLS_REQUIRED])
+ WAYLAND_PROTOCOLS_DATADIR=`$PKG_CONFIG --variable=pkgdatadir wayland-protocols`
+
+- PKG_CHECK_MODULES([WAYLAND_SCANNER], [wayland-scanner],
+- WAYLAND_SCANNER=`$PKG_CONFIG --variable=wayland_scanner wayland-scanner`,
+- WAYLAND_SCANNER='')
+- if test "x$WAYLAND_SCANNER" = x; then
+- AC_PATH_PROG([WAYLAND_SCANNER], [wayland-scanner], [:])
+- fi
++ AC_PATH_PROG([WAYLAND_SCANNER], [wayland-scanner], [:])
+
+ if test "x$WAYLAND_SCANNER" = "x:"; then
+ AC_MSG_ERROR([wayland-scanner is needed to compile the wayland platform])
+--
+2.17.1
+