aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libsdl
diff options
context:
space:
mode:
authorKang Kai <kai.kang@windriver.com>2012-03-14 17:03:38 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-14 13:12:43 +0000
commit94e18a1c574b97ba87724c0fea79d2af77ba4186 (patch)
tree95b1369daf93a6325fb2b4f8e22f1a06624f7367 /meta/recipes-graphics/libsdl
parente28f5ca21f07040e1c62ccd65c94e2df734770e4 (diff)
downloadopenembedded-core-contrib-94e18a1c574b97ba87724c0fea79d2af77ba4186.tar.gz
libsdl: update to 1.2.15
Update libsdl to 1.2.15. Patch add.XGetRequest.symbol.patch is merged by upstream, so remove it. Signed-off-by: Kang Kai <kai.kang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/libsdl')
-rw-r--r--meta/recipes-graphics/libsdl/libsdl-1.2.14/add.XGetRequest.symbol.patch79
-rw-r--r--meta/recipes-graphics/libsdl/libsdl-1.2.15/configure_tweak.patch (renamed from meta/recipes-graphics/libsdl/libsdl-1.2.14/configure_tweak.patch)0
-rw-r--r--meta/recipes-graphics/libsdl/libsdl_1.2.15.bb (renamed from meta/recipes-graphics/libsdl/libsdl_1.2.14.bb)7
3 files changed, 3 insertions, 83 deletions
diff --git a/meta/recipes-graphics/libsdl/libsdl-1.2.14/add.XGetRequest.symbol.patch b/meta/recipes-graphics/libsdl/libsdl-1.2.14/add.XGetRequest.symbol.patch
deleted file mode 100644
index 33ba8ecde9..0000000000
--- a/meta/recipes-graphics/libsdl/libsdl-1.2.14/add.XGetRequest.symbol.patch
+++ /dev/null
@@ -1,79 +0,0 @@
-From e49fe9e2d75764d2d7ef79ab4252a1f6b99adcd3 Mon Sep 17 00:00:00 2001
-From: Martin Jansa <martin.jansa@gmail.com>
-Date: Thu, 23 Feb 2012 18:38:19 +0100
-Subject: [PATCH] _XGetRequest API was backported to libx11-1.4.4 in:
- http://git.openembedded.org/openembedded-core/commit/?id=e08604800fe1cb8f240f53c147ceb4ee08a29b91
-
-This breaks e.g. libsdl-image build with:
-| /OE/shr-core/tmp-eglibc/sysroots/qemux86-64/usr/lib/libSDL.so: undefined reference to `_XGetRequest'
-
-For details see: https://bugzilla.redhat.com/show_bug.cgi?id=782251
-
-Upstream-Status: Accepted
----
- src/video/x11/SDL_x11dyn.c | 24 ++++++++++++++++++++++++
- src/video/x11/SDL_x11sym.h | 6 ++++++
- 2 files changed, 30 insertions(+), 0 deletions(-)
-
-diff --git a/src/video/x11/SDL_x11dyn.c b/src/video/x11/SDL_x11dyn.c
-index 4e549b3..a7e800e 100644
---- a/src/video/x11/SDL_x11dyn.c
-+++ b/src/video/x11/SDL_x11dyn.c
-@@ -109,6 +109,21 @@ char *(*pXGetICValues)(XIC, ...) = NULL;
- #undef SDL_X11_SYM
-
-
-+static void *SDL_XGetRequest_workaround(Display* dpy, CARD8 type, size_t len)
-+{
-+ xReq *req;
-+ WORD64ALIGN
-+ if (dpy->bufptr + len > dpy->bufmax)
-+ _XFlush(dpy);
-+ dpy->last_req = dpy->bufptr;
-+ req = (xReq*)dpy->bufptr;
-+ req->reqType = type;
-+ req->length = len / 4;
-+ dpy->bufptr += len;
-+ dpy->request++;
-+ return req;
-+}
-+
- static int x11_load_refcount = 0;
-
- void SDL_X11_UnloadSymbols(void)
-@@ -168,6 +183,15 @@ int SDL_X11_LoadSymbols(void)
- X11_GetSym("XGetICValues",&SDL_X11_HAVE_UTF8,(void **)&pXGetICValues);
- #endif
-
-+ /*
-+ * In case we're built with newer Xlib headers, we need to make sure
-+ * that _XGetRequest() is available, even on older systems.
-+ * Otherwise, various Xlib macros we use will call a NULL pointer.
-+ */
-+ if (!SDL_X11_HAVE_XGETREQUEST) {
-+ p_XGetRequest = SDL_XGetRequest_workaround;
-+ }
-+
- if (SDL_X11_HAVE_BASEXLIB) { /* all required symbols loaded. */
- SDL_ClearError();
- } else {
-diff --git a/src/video/x11/SDL_x11sym.h b/src/video/x11/SDL_x11sym.h
-index 3dfa146..f1e7841 100644
---- a/src/video/x11/SDL_x11sym.h
-+++ b/src/video/x11/SDL_x11sym.h
-@@ -170,6 +170,12 @@ SDL_X11_SYM(void,_XRead32,(Display *dpy,register long *data,long len),(dpy,data,
- #endif
-
- /*
-+ * libX11 1.4.99.1 added _XGetRequest, and macros use it behind the scenes.
-+ */
-+SDL_X11_MODULE(XGETREQUEST)
-+SDL_X11_SYM(void *,_XGetRequest,(Display* a,CARD8 b,size_t c),(a,b,c),return)
-+
-+/*
- * These only show up on some variants of Unix.
- */
- #if defined(__osf__)
---
-1.7.2.5
-
diff --git a/meta/recipes-graphics/libsdl/libsdl-1.2.14/configure_tweak.patch b/meta/recipes-graphics/libsdl/libsdl-1.2.15/configure_tweak.patch
index 07bda6df02..07bda6df02 100644
--- a/meta/recipes-graphics/libsdl/libsdl-1.2.14/configure_tweak.patch
+++ b/meta/recipes-graphics/libsdl/libsdl-1.2.15/configure_tweak.patch
diff --git a/meta/recipes-graphics/libsdl/libsdl_1.2.14.bb b/meta/recipes-graphics/libsdl/libsdl_1.2.15.bb
index 5c9e6456b2..8b394428dc 100644
--- a/meta/recipes-graphics/libsdl/libsdl_1.2.14.bb
+++ b/meta/recipes-graphics/libsdl/libsdl_1.2.15.bb
@@ -18,17 +18,16 @@ DEPENDS = "${@base_contains('DISTRO_FEATURES', 'directfb', 'directfb', '', d)} \
tslib"
DEPENDS_virtclass-nativesdk = "${@base_contains('DISTRO_FEATURES', 'x11', 'libx11-nativesdk libxrandr-nativesdk libxrender-nativesdk libxext-nativesdk', '', d)}"
-PR = "r7"
+PR = "r0"
SRC_URI = "http://www.libsdl.org/release/SDL-${PV}.tar.gz \
file://configure_tweak.patch \
- file://add.XGetRequest.symbol.patch \
"
S = "${WORKDIR}/SDL-${PV}"
-SRC_URI[md5sum] = "e52086d1b508fa0b76c52ee30b55bec4"
-SRC_URI[sha256sum] = "5d927e287034cb6bb0ebccfa382cb1d185cb113c8ab5115a0759798642eed9b6"
+SRC_URI[md5sum] = "9d96df8417572a2afb781a7c4c811a85"
+SRC_URI[sha256sum] = "d6d316a793e5e348155f0dd93b979798933fb98aa1edebcc108829d6474aad00"
inherit autotools lib_package binconfig pkgconfig