aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libsdl
diff options
context:
space:
mode:
authorJiajun Xu <jiajun.xu@intel.com>2011-08-15 20:57:21 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-08-15 15:13:34 +0100
commit2d719f69676e9a64f7baf34f058441b887dfa14a (patch)
treecb80eb39669979b4cff47acf1cdf1426180105a8 /meta/recipes-graphics/libsdl
parent74f7e5c683dfd71c4042789b8dd4908f76f7e07a (diff)
downloadopenembedded-core-contrib-2d719f69676e9a64f7baf34f058441b887dfa14a.tar.gz
libsdl: add target version
Rename libsdl-nativesdk to libsdl to enable target version. libsdl is needed in some graphics testing. Signed-off-by: Jiajun Xu <jiajun.xu@intel.com> Acked-by: Phil Blundell <philb@gnu.org>
Diffstat (limited to 'meta/recipes-graphics/libsdl')
-rw-r--r--meta/recipes-graphics/libsdl/libsdl_1.2.11.bb (renamed from meta/recipes-graphics/libsdl/libsdl-nativesdk_1.2.11.bb)20
1 files changed, 15 insertions, 5 deletions
diff --git a/meta/recipes-graphics/libsdl/libsdl-nativesdk_1.2.11.bb b/meta/recipes-graphics/libsdl/libsdl_1.2.11.bb
index e64a62e668..7c1c507666 100644
--- a/meta/recipes-graphics/libsdl/libsdl-nativesdk_1.2.11.bb
+++ b/meta/recipes-graphics/libsdl/libsdl_1.2.11.bb
@@ -1,17 +1,25 @@
-DESCRIPTION = "Simple DirectMedia Layer - native Edition"
+SUMMARY = "Simple DirectMedia Layer"
+DESCRIPTION = "Simple DirectMedia Layer is a cross-platform multimedia \
+library designed to provide low level access to audio, keyboard, mouse, \
+joystick, 3D hardware via OpenGL, and 2D video framebuffer."
HOMEPAGE = "http://www.libsdl.org"
+BUGTRACKER = "http://bugzilla.libsdl.org/"
+
SECTION = "libs"
-LICENSE = "LGPLv2.1"
-DEPENDS = "libx11-nativesdk libxext-nativesdk libxrandr-nativesdk libxrender-nativesdk"
-RDEPENDS_${PN} = "libx11-nativesdk libxrandr-nativesdk libxrender-nativesdk libxext-nativesdk"
-PR = "r5"
+LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=27818cd7fd83877a8e3ef82b82798ef4"
+DEPENDS = "virtual/libx11 libxext libxrandr libxrender"
+DEPENDS_virtclass-nativesdk = "libx11-nativesdk libxrandr-nativesdk libxrender-nativesdk libxext-nativesdk"
+
+PR = "r6"
+
SRC_URI = "http://www.libsdl.org/release/SDL-${PV}.tar.gz \
file://acinclude.m4 \
file://configure_tweak.patch;patch=1 \
file://kernel-asm-page.patch;patch=1 "
+
S = "${WORKDIR}/SDL-${PV}"
SRC_URI[md5sum] = "418b42956b7cd103bfab1b9077ccc149"
@@ -34,3 +42,5 @@ PARALLEL_MAKE = ""
do_configure_prepend() {
cp ${WORKDIR}/acinclude.m4 ${S}/acinclude.m4
}
+
+BBCLASSEXTEND = "nativesdk"