aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libsdl
diff options
context:
space:
mode:
authorJiajun Xu <jiajun.xu@intel.com>2011-08-15 20:58:42 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-08-15 15:26:20 +0100
commit92b2e942e1e98492c73a7b888f00975c2423673a (patch)
treecfc792803418b92830a4a439902c63c1bcda8e92 /meta/recipes-graphics/libsdl
parent9939c3664e8cfa2ad0308958ad1281a71c35af00 (diff)
downloadopenembedded-core-contrib-92b2e942e1e98492c73a7b888f00975c2423673a.tar.gz
libsdl: enable opengl for libsdl
To enable opengl for libsdl, we need DEPENDS on virtual/libgl. Add a check for "opengl" in DISTRO_FEATURES and when it's set, "--enable-video-opengl" and "virtual/libgl" will be added into EXTRA_CONF and DEPENDS. (From OE-Core rev: c28e62125209aa2e9606f094a4100ac1107fdd28) Signed-off-by: Jiajun Xu <jiajun.xu@intel.com> Acked-by: Phil Blundell <philb@gnu.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/libsdl')
-rw-r--r--meta/recipes-graphics/libsdl/libsdl_1.2.11.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta/recipes-graphics/libsdl/libsdl_1.2.11.bb b/meta/recipes-graphics/libsdl/libsdl_1.2.11.bb
index 7c1c507666..f08077d8d2 100644
--- a/meta/recipes-graphics/libsdl/libsdl_1.2.11.bb
+++ b/meta/recipes-graphics/libsdl/libsdl_1.2.11.bb
@@ -10,10 +10,10 @@ SECTION = "libs"
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=27818cd7fd83877a8e3ef82b82798ef4"
-DEPENDS = "virtual/libx11 libxext libxrandr libxrender"
+DEPENDS = "${@base_contains('DISTRO_FEATURES', 'opengl', 'virtual/libgl', '', d)} virtual/libx11 libxext libxrandr libxrender"
DEPENDS_virtclass-nativesdk = "libx11-nativesdk libxrandr-nativesdk libxrender-nativesdk libxext-nativesdk"
-PR = "r6"
+PR = "r7"
SRC_URI = "http://www.libsdl.org/release/SDL-${PV}.tar.gz \
file://acinclude.m4 \
@@ -33,7 +33,8 @@ EXTRA_OECONF = "--disable-static --disable-debug --disable-cdrom --enable-thread
--disable-mintaudio --disable-nasm --enable-video-x11 --disable-video-dga \
--disable-video-fbcon --disable-video-directfb --disable-video-ps2gs \
--disable-video-xbios --disable-video-gem --disable-video-dummy \
- --disable-video-opengl --enable-input-events --enable-pthreads \
+ --enable-input-events --enable-pthreads \
+ ${@base_contains('DISTRO_FEATURES', 'opengl', '--enable-video-opengl', '--disable-video-opengl', d)} \
--disable-video-svga \
--disable-video-picogui --disable-video-qtopia --enable-dlopen"