aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libepoxy/libepoxy_git.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2015-05-21 14:42:16 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-24 07:19:18 +0100
commitc1eefc5a4bee25dcf9f8fbe57dc980e9fe352cf7 (patch)
tree5a503e585296293e396c0f4481ff1a771dca6575 /meta/recipes-graphics/libepoxy/libepoxy_git.bb
parent887fcb565381c59b1cc0b3426e1188baf030f2da (diff)
downloadopenembedded-core-contrib-c1eefc5a4bee25dcf9f8fbe57dc980e9fe352cf7.tar.gz
libepoxy: make buildable for x11-less environments / update to latest version
* Make glx part configurable by PACKAGECONFIG enabled by 'x11' distro feature * Major upstream enhancement is using pkgconfig for egl. This should make those egl implementations happy that require compiler extra options for their egl headers. Example: meta-fsl-arm/imx-gpu-viv sets -DLINUX (and others) in egl.pc. These are mandatory for proper builds. (From OE-Core rev: 7bbd34c0efd0f7d65edb7187abdde695e45f62e2) Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/libepoxy/libepoxy_git.bb')
-rw-r--r--meta/recipes-graphics/libepoxy/libepoxy_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libepoxy/libepoxy_git.bb b/meta/recipes-graphics/libepoxy/libepoxy_git.bb
new file mode 100644
index 0000000000..9816257495
--- /dev/null
+++ b/meta/recipes-graphics/libepoxy/libepoxy_git.bb
@@ -0,0 +1,24 @@
+SUMMARY = "OpenGL function pointer management library"
+HOMEPAGE = "https://github.com/anholt/libepoxy/"
+SECTION = "libs"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=58ef4c80d401e07bd9ee8b6b58cf464b"
+
+
+SRC_URI = " \
+ git://github.com/anholt/libepoxy.git \
+ file://0001-select-platforms-based-on-configuration-results.patch \
+ file://0002-add-an-option-to-disable-glx-support.patch \
+"
+SRCREV="20062c25e7612cab023cdef44d3277ba1bd0b2de"
+PV = "1.2+git${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+DEPENDS = "util-macros virtual/egl"
+
+PACKAGECONFIG[x11] = "--enable-glx, --disable-glx, virtual/libx11"
+PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"