summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/kmscube/kmscube_git.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-01-23 17:17:42 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-26 13:39:37 +0000
commit58232c6df8619e715a2f1d5532b9b535b3dbe343 (patch)
tree3f1df3cd576cc8f4af458b5f7aa0360eaf31845c /meta/recipes-graphics/kmscube/kmscube_git.bb
parentbf42364186a1ab0dfe1aa313f843b712f1c38abf (diff)
downloadopenembedded-core-contrib-58232c6df8619e715a2f1d5532b9b535b3dbe343.tar.gz
kmscube: make gstreamer dependency optional
This in particular saves build times for virgl oe-selftest. (From OE-Core rev: 7f1f3b45329ea3f43d0ede003e8daa9866bf9f6e) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/kmscube/kmscube_git.bb')
-rw-r--r--meta/recipes-graphics/kmscube/kmscube_git.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-graphics/kmscube/kmscube_git.bb b/meta/recipes-graphics/kmscube/kmscube_git.bb
index c6cb184215..b2dd6b30b0 100644
--- a/meta/recipes-graphics/kmscube/kmscube_git.bb
+++ b/meta/recipes-graphics/kmscube/kmscube_git.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Demo application to showcase 3D graphics using kms and gbm"
HOMEPAGE = "https://cgit.freedesktop.org/mesa/kmscube/"
LICENSE = "MIT"
SECTION = "graphics"
-DEPENDS = "virtual/libgles2 virtual/egl libdrm gstreamer1.0 gstreamer1.0-plugins-base"
+DEPENDS = "virtual/libgles2 virtual/egl libdrm"
LIC_FILES_CHKSUM = "file://kmscube.c;beginline=1;endline=23;md5=8b309d4ee67b7315ff7381270dd631fb"
@@ -16,3 +16,6 @@ S = "${WORKDIR}/git"
inherit meson pkgconfig distro_features_check
REQUIRED_DISTRO_FEATURES = "opengl"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[gstreamer] = "-Dgstreamer=enabled,-Dgstreamer=disabled,gstreamer1.0 gstreamer1.0-plugins-base"