summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/harfbuzz/harfbuzz_2.6.1.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-09-04 18:10:49 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-09-06 14:58:10 +0100
commit57428a8f146841755d3b9eaef1382f60813e5a3a (patch)
treecf198f24551e0e84172e45735e397a49d65b06df /meta/recipes-graphics/harfbuzz/harfbuzz_2.6.1.bb
parent3c42048c2082da4a0ddc79fe757fc5a2ce5bcd89 (diff)
downloadopenembedded-core-contrib-57428a8f146841755d3b9eaef1382f60813e5a3a.tar.gz
harfbuzz: upgrade to 2.6.1
Add a (disabled) PACKAGECONFIG for Graphite2. Update the license checksum for hb-ucd.cc, which for some reason was checksumming the entire file and not just the license header. (From OE-Core rev: 6e097c853f17ec76b61440bb868371ddf6a8e977) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/harfbuzz/harfbuzz_2.6.1.bb')
-rw-r--r--meta/recipes-graphics/harfbuzz/harfbuzz_2.6.1.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-graphics/harfbuzz/harfbuzz_2.6.1.bb b/meta/recipes-graphics/harfbuzz/harfbuzz_2.6.1.bb
new file mode 100644
index 0000000000..b0f565b9b0
--- /dev/null
+++ b/meta/recipes-graphics/harfbuzz/harfbuzz_2.6.1.bb
@@ -0,0 +1,39 @@
+SUMMARY = "Text shaping library"
+DESCRIPTION = "HarfBuzz is an OpenType text shaping engine."
+HOMEPAGE = "http://www.freedesktop.org/wiki/Software/HarfBuzz"
+BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=HarfBuzz"
+SECTION = "libs"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=e11f5c3149cdec4bb309babb020b32b9 \
+ file://src/hb-ucd.cc;beginline=1;endline=15;md5=29d4dcb6410429195df67efe3382d8bc"
+
+DEPENDS = "glib-2.0 cairo fontconfig freetype"
+
+SRC_URI = "http://www.freedesktop.org/software/harfbuzz/release/${BP}.tar.xz"
+SRC_URI[md5sum] = "89b758a2eb14d56a94406cf914b62388"
+SRC_URI[sha256sum] = "c651fb3faaa338aeb280726837c2384064cdc17ef40539228d88a1260960844f"
+
+inherit autotools pkgconfig lib_package gtk-doc
+
+PACKAGECONFIG ??= "icu"
+PACKAGECONFIG[icu] = "--with-icu,--without-icu,icu"
+PACKAGECONFIG[graphite] = "--with-graphite2,--without-graphite2,graphite2"
+
+EXTRA_OECONF = " \
+ --with-cairo \
+ --with-fontconfig \
+ --with-freetype \
+ --with-glib \
+"
+
+PACKAGES =+ "${PN}-icu ${PN}-icu-dev"
+
+LEAD_SONAME = "libharfbuzz.so"
+
+FILES_${PN}-icu = "${libdir}/libharfbuzz-icu.so.*"
+FILES_${PN}-icu-dev = "${libdir}/libharfbuzz-icu.la \
+ ${libdir}/libharfbuzz-icu.so \
+ ${libdir}/pkgconfig/harfbuzz-icu.pc \
+"
+
+BBCLASSEXTEND = "native nativesdk"