summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/glslang/glslang_1.3.216.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-06-21 22:16:25 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-06-22 22:40:25 +0100
commitdab46fa6a98af448d7bf1291f1de4edb3590f66a (patch)
tree6c857542c77e450872a56734859c347c1665c375 /meta/recipes-graphics/glslang/glslang_1.3.216.0.bb
parent5057ffe70cb1fc114b3143a9e7ce3d15964c68c8 (diff)
downloadopenembedded-core-contrib-dab46fa6a98af448d7bf1291f1de4edb3590f66a.tar.gz
vulkan: upgrade 1.3.211.0 -> 1.3.216.0
Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/glslang/glslang_1.3.216.0.bb')
-rw-r--r--meta/recipes-graphics/glslang/glslang_1.3.216.0.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-graphics/glslang/glslang_1.3.216.0.bb b/meta/recipes-graphics/glslang/glslang_1.3.216.0.bb
new file mode 100644
index 0000000000..69d9a0a84e
--- /dev/null
+++ b/meta/recipes-graphics/glslang/glslang_1.3.216.0.bb
@@ -0,0 +1,32 @@
+SUMMARY = "OpenGL / OpenGL ES Reference Compiler"
+DESCRIPTION = "Glslang is the official reference compiler front end for the \
+OpenGL ES and OpenGL shading languages. It implements a strict interpretation \
+of the specifications for these languages. It is open and free for anyone to use, \
+either from a command line or programmatically."
+SECTION = "graphics"
+HOMEPAGE = "https://www.khronos.org/opengles/sdk/tools/Reference-Compiler"
+LICENSE = "BSD-3-Clause & BSD-2-Clause & MIT & Apache-2.0 & GPL-3-with-bison-exception"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2a2b5acd7bc4844964cfda45fe807dc3"
+
+SRCREV = "adbf0d3106b26daa237b10b9bf72b1af7c31092d"
+SRC_URI = "git://github.com/KhronosGroup/glslang.git;protocol=https;branch=master \
+ file://0001-generate-glslang-pkg-config.patch"
+PE = "1"
+UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"
+S = "${WORKDIR}/git"
+
+inherit cmake python3native
+
+EXTRA_OECMAKE = " \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DBUILD_SHARED_LIBS=ON \
+ -DENABLE_PCH=OFF \
+ -DENABLE_CTEST=OFF \
+ -DBUILD_EXTERNAL=OFF \
+"
+
+SOLIBSDEV = "glslang.so"
+# all the other libraries are unversioned, so pack it on PN
+FILES:${PN} += "${libdir}/*.so"
+
+BBCLASSEXTEND = "native nativesdk"