summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/glew/glew/notempdir.patch
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-09-27 10:58:08 +0100
committerSteve Sakoman <steve@sakoman.com>2021-09-30 04:20:38 -1000
commitd12c44df66ca065a1526c7d6885e726cf50aab46 (patch)
treecb2ba17c7ccf3a99f306c11385cd985c785c2a32 /meta/recipes-graphics/glew/glew/notempdir.patch
parent15db91abd152aa3d22d24f951ba7663ab59ff7eb (diff)
downloadopenembedded-core-contrib-d12c44df66ca065a1526c7d6885e726cf50aab46.tar.gz
glew: Stop polluting /tmp during builds
Currently the glew code creates a new directory in /tmp for each make invocation. This is a bit ugly, don't do that. The patch does break the dist targets but we don't use them. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 3a55194f90e11da5671b24391a4aaf2b86a8e1e6) Signed-off-by: Steve Sakoman <steve@sakoman.com>
Diffstat (limited to 'meta/recipes-graphics/glew/glew/notempdir.patch')
-rw-r--r--meta/recipes-graphics/glew/glew/notempdir.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-graphics/glew/glew/notempdir.patch b/meta/recipes-graphics/glew/glew/notempdir.patch
new file mode 100644
index 0000000000..8d79ce0cdf
--- /dev/null
+++ b/meta/recipes-graphics/glew/glew/notempdir.patch
@@ -0,0 +1,19 @@
+We don't use the dist-* targets and hence DIST_DIR isn't used. The current code
+creates a new temp directory in /tmp/ for every invocation of make. Lets
+not do that.
+
+Upstream-Status: Pending [a revised version would be needed for upstream]
+Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
+
+Index: glew-2.2.0/Makefile
+===================================================================
+--- glew-2.2.0.orig/Makefile
++++ glew-2.2.0/Makefile
+@@ -56,7 +56,6 @@ DIST_SRC_ZIP ?= $(shell pwd)/$(DIST_NAME
+ DIST_SRC_TGZ ?= $(shell pwd)/$(DIST_NAME).tgz
+ DIST_WIN32 ?= $(shell pwd)/$(DIST_NAME)-win32.zip
+
+-DIST_DIR := $(shell mktemp -d /tmp/glew.XXXXXX)/$(DIST_NAME)
+
+ # To disable stripping of linked binaries either:
+ # - use STRIP= on gmake command-line