aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/freetype
diff options
context:
space:
mode:
authorMing Liu <ming.liu@windriver.com>2014-04-07 19:27:18 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-04-09 09:53:14 +0100
commitd06a10a54a445cc7f86d22ff0a74135f94f9f77b (patch)
tree84ebfdfce79a0542a147967bd1fcb5d3fd9666a0 /meta/recipes-graphics/freetype
parentb3f71950616228fb378da9173345cc341018e101 (diff)
downloadopenembedded-core-contrib-d06a10a54a445cc7f86d22ff0a74135f94f9f77b.tar.gz
freetype: fix multilib header conflict - ftconfig.h
ftconfig.h conflicts between 32-bit and 64-bit versions. (From OE-Core rev: 590446f6b191b32efc462c3cb7ac7cce4c897b05) Signed-off-by: Ming Liu <ming.liu@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/freetype')
-rw-r--r--meta/recipes-graphics/freetype/freetype_2.5.2.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-graphics/freetype/freetype_2.5.2.bb b/meta/recipes-graphics/freetype/freetype_2.5.2.bb
index b93453ae59..0c62a678cd 100644
--- a/meta/recipes-graphics/freetype/freetype_2.5.2.bb
+++ b/meta/recipes-graphics/freetype/freetype_2.5.2.bb
@@ -21,7 +21,7 @@ SRC_URI[sha256sum] = "4ff4bd393aa01071ec7b849d035508a505a78f88b2bcf25ff11e58e43c
S = "${WORKDIR}/freetype-${PV}"
-inherit autotools-brokensep pkgconfig binconfig
+inherit autotools-brokensep pkgconfig binconfig multilib_header
LIBTOOL = "${S}/builds/unix/${HOST_SYS}-libtool"
EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
@@ -50,5 +50,9 @@ do_compile_prepend() {
${BUILD_CC} -o objs/apinames src/tools/apinames.c
}
+do_install_append() {
+ oe_multilib_header freetype2/config/ftconfig.h
+}
+
BBCLASSEXTEND = "native"