aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/freetype/freetype_2.6.3.bb
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2016-02-10 15:19:38 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-11 22:32:18 +0000
commit798aa553e46e0141c8998399820510812d5e51b7 (patch)
treee737a25417a9ffcb968ce5563fbab299c54d387d /meta/recipes-graphics/freetype/freetype_2.6.3.bb
parent77c8871c165c36a70f77b76ff6bd4c2b8be63e96 (diff)
downloadopenembedded-core-contrib-798aa553e46e0141c8998399820510812d5e51b7.tar.gz
freetype: update 2.6.2 -> 2.6.3
Update LICENSE.TXT hash due to minor rewording to clarify licensing of fthash.c and fthash.h files. No changes to overall licensing. Other changes from the upstream changelog: I. IMPORTANT CHANGES - Khmer, Myanmar, Bengali, and Kannada script support has been added to the auto-hinter. II. MISCELLANEOUS - Better support of Indic scripts like Devanagari by using a top-to-bottom hinting flow. - All FreeType macros starting with two underscores have been renamed to avoid a violation of both the C and C++ standards. Example: Header macros of the form `__FOO_H__' are now called `FOO_H_'. In most cases, this should be completely transparent to the user. The exception to this is `__FTERRORS_H__', which must be sometimes undefined by the user to get FreeType error strings: Both this form and the new `FTERRORS_H_' macro are accepted for backwards compatibility. - Minor improvements mainly to the Type 1 driver. - The new CFF engine now supports all Type 2 operators except `random'. - The macro `_STANDALONE_', used for compiling the B/W and smooth rasterizers as stand-alone modules, has been renamed to `STANDALONE_', since macro names starting with an underscore and followed by an uppercase letter are reserved in both C and C++. - Function `FT_Library_SetLcdFilterWeights' now also activates custom LCD filter weights (instead of just adjusting them). - Support for `unpatented hinting' has been completely removed: Consequently, the two functions `FT_Face_CheckTrueTypePatents' and `FT_Face_SetUnpatentedHinting' now return always false, doing nothing. - The `ftgamma' demo program has been modernized; the gamma grid display has been moved from `ftview' to this program. - It is now possible to cycle through the available LCD fitlering modes. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/freetype/freetype_2.6.3.bb')
-rw-r--r--meta/recipes-graphics/freetype/freetype_2.6.3.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/meta/recipes-graphics/freetype/freetype_2.6.3.bb b/meta/recipes-graphics/freetype/freetype_2.6.3.bb
new file mode 100644
index 0000000000..cf6882af9e
--- /dev/null
+++ b/meta/recipes-graphics/freetype/freetype_2.6.3.bb
@@ -0,0 +1,54 @@
+SUMMARY = "Freetype font rendering library"
+DESCRIPTION = "FreeType is a software font engine that is designed to be small, efficient, \
+highly customizable, and portable while capable of producing high-quality output (glyph \
+images). It can be used in graphics libraries, display servers, font conversion tools, text \
+image generation tools, and many other products as well."
+HOMEPAGE = "http://www.freetype.org/"
+BUGTRACKER = "https://savannah.nongnu.org/bugs/?group=freetype"
+SECTION = "libs"
+
+LICENSE = "FreeType | GPLv2+"
+LIC_FILES_CHKSUM = "file://docs/LICENSE.TXT;md5=4af6221506f202774ef74f64932878a1 \
+ file://docs/FTL.TXT;md5=d479e83797f699fe873b38dadd0fcd4c \
+ file://docs/GPLv2.TXT;md5=8ef380476f642c20ebf40fecb0add2ec"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/freetype/freetype-${PV}.tar.bz2 \
+ file://use-right-libtool.patch"
+
+SRC_URI[md5sum] = "0037b25a8c090bc8a1218e867b32beb1"
+SRC_URI[sha256sum] = "371e707aa522acf5b15ce93f11183c725b8ed1ee8546d7b3af549863045863a2"
+
+inherit autotools pkgconfig binconfig-disabled multilib_header
+
+PACKAGECONFIG ??= "zlib"
+
+PACKAGECONFIG[bzip2] = "--with-bzip2,--without-bzip2,bzip2"
+# harfbuzz results in a circular dependency so enabling is non-trivial
+PACKAGECONFIG[harfbuzz] = "--with-harfbuzz,--without-harfbuzz,harfbuzz"
+PACKAGECONFIG[pixmap] = "--with-png,--without-png,libpng"
+PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib"
+
+EXTRA_OECONF = "CC_BUILD='${BUILD_CC}'"
+
+TARGET_CPPFLAGS += "-D_FILE_OFFSET_BITS=64"
+
+do_configure() {
+ # Need this because although the autotools infrastructure is in
+ # builds/unix the configure script get written to ${S}, so we can't
+ # just use AUTOTOOLS_SCRIPT_PATH.
+ cd ${S}/builds/unix
+ libtoolize --force --copy
+ aclocal -I .
+ gnu-configize --force
+ autoconf
+ cd ${B}
+ oe_runconf
+}
+
+do_install_append() {
+ oe_multilib_header freetype2/freetype/config/ftconfig.h
+}
+
+BINCONFIG = "${bindir}/freetype-config"
+
+BBCLASSEXTEND = "native"