aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/fontconfig/fontconfig_2.10.2.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-02-11 16:03:09 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-11 22:46:47 +0000
commitba3db5f5e7055d597b21d8b5f8e60bc3c4f12bd2 (patch)
tree5f94b85ce79e34b13e0020c2608ad58e98bdd493 /meta/recipes-graphics/fontconfig/fontconfig_2.10.2.bb
parenta96e2c84f24c15b77ee1fbc1f998b8b4796b8664 (diff)
downloadopenembedded-core-contrib-ba3db5f5e7055d597b21d8b5f8e60bc3c4f12bd2.tar.gz
fontconfig: remove unexplainable and broken build tweaking
The build flag twiddling in do_configure_append was unexplainable and clearly wrong (native flags for a cross build), remove it all. Parallel make appears to be working now, so enable it. The tarball doesn't contain read only sources, remove the unpack hacking. The pkgconfig doesn't need patching as the freetype link lines are the same. Don't need to specify where freetype is, it's found automatically. Merge fontconfig-util-dbg into fontconfig-dbg. Don't export HASDOCBOOK, --disable-docs is sufficient to turn off documentation building. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/fontconfig/fontconfig_2.10.2.bb')
-rw-r--r--meta/recipes-graphics/fontconfig/fontconfig_2.10.2.bb47
1 files changed, 3 insertions, 44 deletions
diff --git a/meta/recipes-graphics/fontconfig/fontconfig_2.10.2.bb b/meta/recipes-graphics/fontconfig/fontconfig_2.10.2.bb
index 607cf9e6da..6f2456d071 100644
--- a/meta/recipes-graphics/fontconfig/fontconfig_2.10.2.bb
+++ b/meta/recipes-graphics/fontconfig/fontconfig_2.10.2.bb
@@ -24,16 +24,14 @@ PR = "r1"
SRC_URI = "http://fontconfig.org/release/fontconfig-${PV}.tar.gz \
file://Add-sysroot-option-to-fc-cache-and-fc-cat.patch \
- file://fix-pkgconfig.patch \
"
SRC_URI[md5sum] = "025e08b3d7fe45c433de5718e441ed15"
SRC_URI[sha256sum] = "5c3bf994bb6d6303bbf1e641eaa4b431932138dc90de33642e5845e31e1fdfd6"
-PACKAGES =+ "fontconfig-utils-dbg fontconfig-utils "
-FILES_fontconfig-utils-dbg = "${bindir}/*.dbg"
-FILES_fontconfig-utils = "${bindir}/*"
+PACKAGES =+ "fontconfig-utils"
FILES_${PN} =+ "${datadir}/xml/*"
+FILES_fontconfig-utils = "${bindir}/*"
# Work around past breakage in debian.bbclass
RPROVIDES_fontconfig-utils = "libfontconfig-utils"
@@ -41,45 +39,6 @@ RREPLACES_fontconfig-utils = "libfontconfig-utils"
RCONFLICTS_fontconfig-utils = "libfontconfig-utils"
DEBIAN_NOAUTONAME_fontconfig-utils = "1"
-PARALLEL_MAKE = ""
-
inherit autotools pkgconfig
-export HASDOCBOOK="no"
-
-EXTRA_OECONF = " --disable-docs --with-arch=${HOST_ARCH} --with-default-fonts=${datadir}/fonts"
-EXTRA_OEMAKE = "FC_LANG=fc-lang FC_GLYPHNAME=fc-glyphname"
-
-# The tarball has some of the patched files as read only, which
-# patch doesn't like at all
-
-fontconfig_do_unpack() {
- chmod -R u+rw ${S}
-}
-
-python do_unpack () {
- bb.build.exec_func('base_do_unpack', d)
- bb.build.exec_func('fontconfig_do_unpack', d)
-}
-
-BUILD_CFLAGS += " -I${STAGING_INCDIR}/freetype2"
-
-do_configure_append () {
- sed -i 's|LDFLAGS =.*|LDFLAGS =|' fc-case/Makefile
- sed -i 's|LDFLAGS =.*|LDFLAGS =|' fc-glyphname/Makefile
- sed -i 's|LDFLAGS =.*|LDFLAGS =|' fc-lang/Makefile
-
- sed -i 's|CFLAGS =.*|CFLAGS =${BUILD_CFLAGS}|' fc-case/Makefile
- sed -i 's|CFLAGS =.*|CFLAGS =${BUILD_CFLAGS}|' fc-glyphname/Makefile
- sed -i 's|CFLAGS =.*|CFLAGS =${BUILD_CFLAGS}|' fc-lang/Makefile
-
- sed -i 's|CPPFLAGS =.*|CPPFLAGS =${BUILD_CPPFLAGS}|' fc-case/Makefile
- sed -i 's|CPPFLAGS =.*|CPPFLAGS =${BUILD_CPPFLAGS}|' fc-glyphname/Makefile
- sed -i 's|CPPFLAGS =.*|CPPFLAGS =${BUILD_CPPFLAGS}|' fc-lang/Makefile
-
- sed -i 's|CXXFLAGS =.*|CFLAGS =${BUILD_CXXFLAGS}|' fc-case/Makefile
- sed -i 's|CXXFLAGS =.*|CFLAGS =${BUILD_CXXFLAGS}|' fc-glyphname/Makefile
- sed -i 's|CXXFLAGS =.*|CFLAGS =${BUILD_CXXFLAGS}|' fc-lang/Makefile
-
-}
-
+EXTRA_OECONF = " --disable-docs --with-default-fonts=${datadir}/fonts"