aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/drm
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-02-11 23:39:54 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-14 11:42:19 +0000
commitbe5b72cf27e580adfb24b1236d4b7719aa0da498 (patch)
treeb63146d6102200815220b22b3feee955def68536 /meta/recipes-graphics/drm
parent5fc5996c23643ef2e0e316f60d587ced545a769f (diff)
downloadopenembedded-core-contrib-be5b72cf27e580adfb24b1236d4b7719aa0da498.tar.gz
libdrm: don't detect components that have been disabled
We pass --disable-cairo-tests but if cairo is in the sysroot it is detected and used, which causes problems in mass builds as cairo could be removed whilst libdrm is being built. (From OE-Core rev: 71882b061bad55f4ad62c7d235a4a629dd74dda8) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/drm')
-rw-r--r--meta/recipes-graphics/drm/libdrm/detect.patch59
-rw-r--r--meta/recipes-graphics/drm/libdrm_2.4.66.bb1
2 files changed, 60 insertions, 0 deletions
diff --git a/meta/recipes-graphics/drm/libdrm/detect.patch b/meta/recipes-graphics/drm/libdrm/detect.patch
new file mode 100644
index 0000000000..6397a5954e
--- /dev/null
+++ b/meta/recipes-graphics/drm/libdrm/detect.patch
@@ -0,0 +1,59 @@
+Upstream-Status: Backport
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+commit 798022b61c58d945f9027c823a188dcedecd3d06
+Author: Marcin Ślusarz <marcin.slusarz@gmail.com>
+Date: Sun Jan 24 13:17:34 2016 +0100
+
+ configure.ac: don't detect disabled options dependencies
+
+ Currently with --disable-amdgpu --disable-valgrind --disable-cairo-tests
+ cunit, valgrind and cairo are still detected.
+
+ Signed-off-by: Marcin Ślusarz <marcin.slusarz@gmail.com>
+ Reviewed-by: Emil Velikov <emil.l.velikov@gmail.com>
+
+diff --git a/configure.ac b/configure.ac
+index 057a846..a09be61 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -363,12 +363,14 @@ fi
+-# Detect cunit library
+-PKG_CHECK_MODULES([CUNIT], [cunit >= 2.1], [have_cunit=yes], [have_cunit=no])
+-# If pkg-config does not find cunit, check it using AC_CHECK_LIB. We
+-# do this because Debian (Ubuntu) lacks pkg-config file for cunit.
+-# fixed in 2.1-2.dfsg-3: http://anonscm.debian.org/cgit/collab-maint/cunit.git/commit/?h=debian
+-if test "x${have_cunit}" = "xno"; then
+- AC_CHECK_LIB([cunit], [CU_initialize_registry], [have_cunit=yes], [have_cunit=no])
+- if test "x${have_cunit}" = "xyes"; then
+- CUNIT_LIBS="-lcunit"
+- CUNIT_CFLAGS=""
+- AC_SUBST([CUNIT_LIBS])
+- AC_SUBST([CUNIT_CFLAGS])
++if test "x$AMDGPU" != xno; then
++ # Detect cunit library
++ PKG_CHECK_MODULES([CUNIT], [cunit >= 2.1], [have_cunit=yes], [have_cunit=no])
++ # If pkg-config does not find cunit, check it using AC_CHECK_LIB. We
++ # do this because Debian (Ubuntu) lacks pkg-config file for cunit.
++ # fixed in 2.1-2.dfsg-3: http://anonscm.debian.org/cgit/collab-maint/cunit.git/commit/?h=debian
++ if test "x${have_cunit}" = "xno"; then
++ AC_CHECK_LIB([cunit], [CU_initialize_registry], [have_cunit=yes], [have_cunit=no])
++ if test "x${have_cunit}" = "xyes"; then
++ CUNIT_LIBS="-lcunit"
++ CUNIT_CFLAGS=""
++ AC_SUBST([CUNIT_LIBS])
++ AC_SUBST([CUNIT_CFLAGS])
++ fi
+@@ -375,0 +378,2 @@ if test "x${have_cunit}" = "xno"; then
++else
++ have_cunit=no
+@@ -404 +408,3 @@ AC_ARG_ENABLE([cairo-tests],
+-PKG_CHECK_MODULES(CAIRO, cairo, [HAVE_CAIRO=yes], [HAVE_CAIRO=no])
++if test "x$CAIRO" != xno; then
++ PKG_CHECK_MODULES(CAIRO, cairo, [HAVE_CAIRO=yes], [HAVE_CAIRO=no])
++fi
+@@ -449 +455,3 @@ AC_ARG_ENABLE(valgrind,
+-PKG_CHECK_MODULES(VALGRIND, [valgrind], [have_valgrind=yes], [have_valgrind=no])
++if test "x$VALGRIND" != xno; then
++ PKG_CHECK_MODULES(VALGRIND, [valgrind], [have_valgrind=yes], [have_valgrind=no])
++fi
diff --git a/meta/recipes-graphics/drm/libdrm_2.4.66.bb b/meta/recipes-graphics/drm/libdrm_2.4.66.bb
index 028db4a4ee..3280920de1 100644
--- a/meta/recipes-graphics/drm/libdrm_2.4.66.bb
+++ b/meta/recipes-graphics/drm/libdrm_2.4.66.bb
@@ -13,6 +13,7 @@ DEPENDS = "libpthread-stubs udev libpciaccess"
SRC_URI = "http://dri.freedesktop.org/libdrm/${BP}.tar.bz2 \
file://installtests.patch \
file://0001-tests-kms-steal-crtc-Include-sys-select.h.patch \
+ file://detect.patch \
"
SRC_URI[md5sum] = "c6809c48538d6e5999588832045ff014"