aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/clutter
diff options
context:
space:
mode:
authorTomas Frydrych <tomas@sleepfive.com>2013-05-21 16:08:42 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-05-24 14:14:44 +0100
commitb7caa5e5cc9aad71a62debf6d7fd9de60c9ccd5b (patch)
tree81b84f65283bb783365bb6f258b7d5f3b54b7fcd /meta/recipes-graphics/clutter
parent32b4a4abd9437db81b0ea70a820b202d40b779e7 (diff)
downloadopenembedded-core-contrib-b7caa5e5cc9aad71a62debf6d7fd9de60c9ccd5b.tar.gz
clutter: further improvements
* Removed unnecessary gtk-doc related depends/configure options (handled in gtk-doc class), * Moved more configure options into PACKAGECONFIG, * Fixed missing comma in PACKAGECONFIG[glx] setup, * Removed no longer required DOLT-related config fragment. (From OE-Core rev: a5d9c80fa35e9fd234f14c61b385d9c17f31132b) Signed-off-by: Tomas Frydrych <tomas@sleepfive.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/clutter')
-rw-r--r--meta/recipes-graphics/clutter/clutter-1.0.inc22
1 files changed, 7 insertions, 15 deletions
diff --git a/meta/recipes-graphics/clutter/clutter-1.0.inc b/meta/recipes-graphics/clutter/clutter-1.0.inc
index 6710776213..e1d3cf42cb 100644
--- a/meta/recipes-graphics/clutter/clutter-1.0.inc
+++ b/meta/recipes-graphics/clutter/clutter-1.0.inc
@@ -6,7 +6,7 @@ inherit clutter
SRC_URI += "file://enable_tests.patch"
-DEPENDS = "gtk-doc-native pango glib-2.0 json-glib atk udev cogl-1.0"
+DEPENDS = "pango glib-2.0 json-glib atk udev cogl-1.0"
PACKAGES =+ "${PN}-examples"
AUTOTOOLS_AUXDIR = "${S}/build"
@@ -18,28 +18,23 @@ EDEPENDS_EVDEV = "libxkbcommon"
ERDEPENDS_EVDEV = "xkeyboard-config"
# Disable pretty much everything, override in platform specific set up
-EXTRA_OECONF += "--disable-gtk-doc \
- ${@get_fpu_setting(bb, d)} \
- --disable-introspection \
- --disable-egl-backend \
+EXTRA_OECONF += "--disable-introspection \
--disable-quartz-backend \
--disable-win32-backend \
- --disable-x11-backend \
--disable-gdk-backend \
--disable-wayland-backend \
--disable-wayland-compositor \
--disable-cex100-backend \
--disable-tslib-input \
- --disable-evdev-input \
"
-PACKAGECONFIG[x11] = "--enable-x11-backend,,${EDEPENDS_X11}"
-PACKAGECONFIG[glx] = "--enable-x11-backend,,${EDEPENDS_X11} ${EDEPENDS_GLX}"
-PACKAGECONFIG[egl] = "--enable-egl-backend,,${EDEPENDS_EGL}"
-PACKAGECONFIG[evdev] = "--enable-evdev-input,,${EDEPENDS_EVDEV},${ERDEPENDS_EVDEV}"
+PACKAGECONFIG[x11] = "--enable-x11-backend,--disable-x11-backend,${EDEPENDS_X11}"
+PACKAGECONFIG[glx] = ",,${EDEPENDS_X11} ${EDEPENDS_GLX}"
+PACKAGECONFIG[egl] = "--enable-egl-backend,--disable-egl-backend,${EDEPENDS_EGL}"
+PACKAGECONFIG[evdev] = "--enable-evdev-input,--disable-evdev-input,${EDEPENDS_EVDEV},${ERDEPENDS_EVDEV}"
# Default configuration, distros might want to override
-PACKAGECONFIG ??= "glx"
+PACKAGECONFIG ??= "x11 glx"
FILES_${PN}-examples = "${bindir}/test-* ${pkgdatadir}/redhand.png"
@@ -50,7 +45,4 @@ do_configure_prepend() {
# see https://bugzilla.gnome.org/show_bug.cgi?id=661128 for this
touch -t 200001010000 po/clutter-1.0.pot
-
- # Disable DOLT
- sed -i -e 's/^DOLT//' ${S}/configure.ac
}