aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/clutter
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-09-11 14:47:11 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-09-11 23:35:44 +0100
commit1b25cf710ea0fdfb73b8b19f8832e34a20a36ee1 (patch)
tree2bc04936a424d04ad23641d99cf0b8f9558abf6d /meta/recipes-graphics/clutter
parent4540f6f6cb5cf3fc1e343e358a083447a74ced5b (diff)
downloadopenembedded-core-contrib-1b25cf710ea0fdfb73b8b19f8832e34a20a36ee1.tar.gz
clutter: fix compilation when building without X11 backend
If Clutter is building the Wayland backend but not the X11 backend, the Cogl support doesn't get enabled so the Wayland backend (which uses it) fails to compile. Backport a fix from upstream to fix this situation. (From OE-Core rev: 6df36a004210901acceff4a201d0f910d99eccfe) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/clutter')
-rw-r--r--meta/recipes-graphics/clutter/clutter-1.0.inc3
-rw-r--r--meta/recipes-graphics/clutter/clutter-1.14/fix-wayland-deps.patch57
2 files changed, 59 insertions, 1 deletions
diff --git a/meta/recipes-graphics/clutter/clutter-1.0.inc b/meta/recipes-graphics/clutter/clutter-1.0.inc
index edc60811ee..1356586fd8 100644
--- a/meta/recipes-graphics/clutter/clutter-1.0.inc
+++ b/meta/recipes-graphics/clutter/clutter-1.0.inc
@@ -4,7 +4,8 @@ LICENSE = "LGPLv2.1+"
inherit clutter
-SRC_URI += "file://enable_tests.patch"
+SRC_URI += "file://enable_tests.patch \
+ file://fix-wayland-deps.patch"
DEPENDS = "pango glib-2.0 json-glib atk udev cogl-1.0"
PACKAGES =+ "${PN}-examples"
diff --git a/meta/recipes-graphics/clutter/clutter-1.14/fix-wayland-deps.patch b/meta/recipes-graphics/clutter/clutter-1.14/fix-wayland-deps.patch
new file mode 100644
index 0000000000..f5af73c9fc
--- /dev/null
+++ b/meta/recipes-graphics/clutter/clutter-1.14/fix-wayland-deps.patch
@@ -0,0 +1,57 @@
+Upstream-Status: Backport
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+From 74f9d8a597acf0fd8458e3d6cb0475b8d9a0a6ba Mon Sep 17 00:00:00 2001
+From: Emmanuele Bassi <ebassi@gnome.org>
+Date: Thu, 27 Jun 2013 16:42:40 +0100
+Subject: [PATCH] build: Enable Cogl support with Wayland
+
+The Wayland backend is based on Cogl, so we need to turn on the
+SUPPORT_COGL flag to avoid breaking the build; this always went
+unnoticed because we usually build the Wayland client backend
+with the X11 backend.
+
+Reported-by: Ross Burton <ross.burton@intel.com>
+(cherry picked from commit 1fb0295ba162507fb798b2b7030f0f45ff252f27)
+
+Signed-off-by: Emmanuele Bassi <ebassi@gnome.org>
+---
+ configure.ac | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index f5afe12..355c95b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -310,6 +310,7 @@ AS_IF([test "x$enable_wayland" = "xyes"],
+ experimental_backend="yes"
+
+ SUPPORT_WAYLAND=1
++ SUPPORT_COGL=1
+
+ PKG_CHECK_EXISTS([wayland-client wayland-cursor xkbcommon gdk-pixbuf-2.0],
+ [
+@@ -337,7 +338,10 @@ AS_IF([test "x$enable_wayland_compositor" = "xyes"],
+ [
+ PKG_CHECK_EXISTS([wayland-server],
+ [BACKEND_PC_FILES="$BACKEND_PC_FILES wayland-server"], [])
++
+ SUPPORT_WAYLAND_COMPOSITOR=1
++ SUPPORT_COGL=1
++
+ CLUTTER_CONFIG_DEFINES="$CLUTTER_CONFIG_DEFINES
+ #define CLUTTER_HAS_WAYLAND_COMPOSITOR_SUPPORT 1"
+ AC_DEFINE([HAVE_CLUTTER_WAYLAND_COMPOSITOR], [1], [Have Wayland compositor support])
+@@ -359,8 +363,8 @@ AS_IF([test "x$enable_cex100" = "xyes"],
+
+ experimental_backend="yes"
+
+- SUPPORT_COGL=1
+ SUPPORT_CEX100=1
++ SUPPORT_COGL=1
+
+ have_gdl=no
+ AC_CHECK_HEADERS([libgdl.h], [have_gdl=yes])
+--
+1.7.10.4
+