aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/clutter/clutter
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2011-01-28 10:01:39 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-02-01 23:59:39 +0000
commit3bb0b9ae97f89507b742cd9b3e03f37c2d928270 (patch)
tree024f846b86bce7074173390ab9b81e0c0a11d612 /meta/recipes-graphics/clutter/clutter
parentba06cc8943d021f406c3d292ce415b77319ca5c6 (diff)
downloadopenembedded-core-contrib-3bb0b9ae97f89507b742cd9b3e03f37c2d928270.tar.gz
clutter-1.0: Upgrade to 1.4 - latest stable version
* Use tar ball release rather than git, as it is more stable. Added dependence on gettext, and one patch to fix the cross-compile failure due to conformance-test. * configure "--with-json=check" avoid extra dependence on external json lib. * rename examples package (clutter-examples-1.x => clutter-1.x-example) to lead the right deploy package name Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
Diffstat (limited to 'meta/recipes-graphics/clutter/clutter')
-rw-r--r--meta/recipes-graphics/clutter/clutter/enable_tests-1.4.patch13
-rw-r--r--meta/recipes-graphics/clutter/clutter/test-conformance-fix.patch66
2 files changed, 79 insertions, 0 deletions
diff --git a/meta/recipes-graphics/clutter/clutter/enable_tests-1.4.patch b/meta/recipes-graphics/clutter/clutter/enable_tests-1.4.patch
new file mode 100644
index 0000000000..52fdcb4c1f
--- /dev/null
+++ b/meta/recipes-graphics/clutter/clutter/enable_tests-1.4.patch
@@ -0,0 +1,13 @@
+Index: git/tests/interactive/Makefile.am
+===================================================================
+--- git.orig/tests/interactive/Makefile.am 2011-01-28 14:06:29.000000000 +0800
++++ git/tests/interactive/Makefile.am 2011-01-28 14:26:59.000000000 +0800
+@@ -107,7 +107,7 @@
+
+ common_ldadd = $(top_builddir)/clutter/libclutter-@CLUTTER_SONAME_INFIX@-@CLUTTER_API_VERSION@.la
+
+-noinst_PROGRAMS = test-interactive
++bin_PROGRAMS = test-interactive
+
+ test_interactive_SOURCES = test-main.c $(UNIT_TESTS)
+ test_interactive_CFLAGS = $(CLUTTER_CFLAGS) $(MAINTAINER_CFLAGS)
diff --git a/meta/recipes-graphics/clutter/clutter/test-conformance-fix.patch b/meta/recipes-graphics/clutter/clutter/test-conformance-fix.patch
new file mode 100644
index 0000000000..ce412ff5af
--- /dev/null
+++ b/meta/recipes-graphics/clutter/clutter/test-conformance-fix.patch
@@ -0,0 +1,66 @@
+Compiling conformance test leads running test-conformance target binary, and
+gets failure in cross-compile environment. Introduce this commit from upstream
+to fix it.
+
+Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
+
+
+commit 7fd6273c25569fe4f37ad371532d93e5170e51f7
+Author: Neil Roberts <neil@linux.intel.com>
+Date: Mon Oct 11 16:16:45 2010 +0100
+
+ tests: Generate the stub scripts using sed
+
+ Instead of trying to run ./test-conformance with the -l option to
+ generate a list of available tests it now runs sed on the
+ test-conform-main.c file instead. Running the generated executable is
+ a pain for cross-compiling so it would be nice to avoid it unless it's
+ absolutely necessary. Although you could tell people who are cross
+ compiling to just disable the conformance tests, this seems a shame
+ because they could still be useful along with the wrappers for example
+ if the cross compile is built to a shared network folder where the
+ tests can be run on the actual device.
+
+ The sed script is a little more ugly than it could be because it tries
+ to avoid using the GNU extensions '\+' and '\|'.
+
+ The script ends up placing restrictions on the format of the C file
+ because the tests must all be listed on one line each. There is now a
+ comment to explain this. Hopefully the trade off is worth it.
+
+ http://bugzilla.clutter-project.org/show_bug.cgi?id=2363
+
+diff --git a/tests/conform/Makefile.am b/tests/conform/Makefile.am
+index 3036639..1e723e7 100644
+--- a/tests/conform/Makefile.am
++++ b/tests/conform/Makefile.am
+@@ -89,9 +89,11 @@ test_conformance_SOURCES = $(common_sources) $(units_sources)
+
+ wrappers: stamp-test-conformance
+ @true
+-stamp-test-conformance: Makefile test-conformance$(EXEEXT)
++stamp-test-conformance: Makefile $(srcdir)/test-conform-main.c
+ @mkdir -p wrappers
+- @( $(abs_builddir)/test-conformance$(EXEEXT) -l -m thorough | $(GREP) '^/' ) > unit-tests
++ @sed -n -e 's/^ \{1,\}TEST_CONFORM_SIMPLE *(.*"\([^",]\{1,\}\)", *\([a-zA-Z0-9_]\{1,\}\).*/\/conform\1\/\2/p' \
++ -e 's/^ \{1,\}TEST_CONFORM_SKIP *(.*"\([^",]\{1,\}\)", *\([a-zA-Z0-9_]\{1,\}\).*/\/conform\1\/\2/p' \
++ $(srcdir)/test-conform-main.c > unit-tests
+ @chmod +x test-launcher.sh
+ @( echo "/stamp-test-conformance" ; \
+ echo "/test-conformance" ; \
+diff --git a/tests/conform/test-conform-main.c b/tests/conform/test-conform-main.c
+index a8b3cf8..2ae7a04 100644
+--- a/tests/conform/test-conform-main.c
++++ b/tests/conform/test-conform-main.c
+@@ -92,6 +92,11 @@ main (int argc, char **argv)
+ {
+ clutter_test_init (&argc, &argv);
+
++ /* This file is run through a sed script during the make step so the
++ lines containing the tests need to be formatted on a single line
++ each. To comment out a test use the SKIP or TODO macros. Using
++ #if 0 would break the script. */
++
+ TEST_CONFORM_SIMPLE ("/timeline", test_timeline);
+ TEST_CONFORM_SKIP (!g_test_slow (), "/timeline", test_timeline_interpolate);
+ TEST_CONFORM_SKIP (!g_test_slow (), "/timeline", test_timeline_rewind);