aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/clutter/clutter/enable_tests-0.6.patch
diff options
context:
space:
mode:
authorTomas Frydrych <tomas@sleepfive.com>2013-05-20 16:05:21 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-05-21 09:14:37 +0100
commit4fbae4449fbb3f5eba499418b374c12bccfb4243 (patch)
tree8cb6ea5ceea62218fe73f0bbc39b19505f932d4f /meta/recipes-graphics/clutter/clutter/enable_tests-0.6.patch
parentb508fdd2b19ca30da8d09caf646897dc4cf195c8 (diff)
downloadopenembedded-core-contrib-4fbae4449fbb3f5eba499418b374c12bccfb4243.tar.gz
clutter: Replace with 1.14.4 version
The package has been renamed to clutter-1.0 instead of clutter-vmajor.vminor, keeping up with the upstream versioning policy (all 1.x packages install clutter-1.0 pc file and headers and are backward compatible), and to simplify dependency management (worth noting that since the 1.x development files are not parall installable, it is not possible to use two versions of clutter 1.x at the same time anyway). Package configuration is provided via PACKAGECONFIG options as follows: 'x11' : enable X11 backend, 'glx' : enable GLX backend, 'egl' : enable EGL backend, 'evdev': enable evdev input backend Default configuration is 'glx'; typical configuration for embedded HW using 'native' EGL would be 'egl evdev'. Signed-off-by: Tomas Frydrych <tomas@sleepfive.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/clutter/clutter/enable_tests-0.6.patch')
-rw-r--r--meta/recipes-graphics/clutter/clutter/enable_tests-0.6.patch42
1 files changed, 0 insertions, 42 deletions
diff --git a/meta/recipes-graphics/clutter/clutter/enable_tests-0.6.patch b/meta/recipes-graphics/clutter/clutter/enable_tests-0.6.patch
deleted file mode 100644
index 8cff0c5fe5..0000000000
--- a/meta/recipes-graphics/clutter/clutter/enable_tests-0.6.patch
+++ /dev/null
@@ -1,42 +0,0 @@
----
- tests/Makefile.am | 7 ++++++-
- tests/test-actors.c | 2 +-
- tests/test-text.c | 2 +-
- 3 files changed, 8 insertions(+), 3 deletions(-)
-
-Upstream-Status: Inappropriate [configuration]
-
-Index: clutter-0-6/tests/Makefile.am
-===================================================================
---- clutter.orig/tests/Makefile.am 2007-11-06 12:29:17.000000000 +0000
-+++ clutter-0-6/tests/Makefile.am 2007-11-06 12:30:11.000000000 +0000
-@@ -1,4 +1,4 @@
--noinst_PROGRAMS = test-textures test-events test-offscreen test-scale \
-+bin_PROGRAMS = test-textures test-events test-offscreen test-scale \
- test-actors test-behave test-text test-entry test-project \
- test-boxes test-perspective test-rotate test-depth \
- test-threads test-timeline test-score test-script
-@@ -26,4 +26,9 @@ test_timeline_SOURCES = test-timeline.c
- test_score_SOURCES = test-score.c
- test_script_SOURCES = test-script.c
-
-+test_textdir = $(pkgdatadir)
-+test_text_DATA = test-text.c
-+test_actorsdir = $(pkgdatadir)
-+test_actors_DATA = redhand.png
-+
- EXTRA_DIST = redhand.png test-script.json
-Index: clutter-0-6/tests/test-actors.c
-===================================================================
---- clutter.orig/tests/test-actors.c 2007-11-06 12:29:17.000000000 +0000
-+++ clutter-0-6/tests/test-actors.c 2007-11-06 12:29:21.000000000 +0000
-@@ -143,7 +143,7 @@ main (int argc, char *argv[])
- stage = clutter_stage_get_default ();
- clutter_actor_set_size (stage, 800, 600);
-
-- pixbuf = gdk_pixbuf_new_from_file ("redhand.png", NULL);
-+ pixbuf = gdk_pixbuf_new_from_file ("/usr/share/clutter/redhand.png", NULL);
-
- if (!pixbuf)
- g_error("pixbuf load failed");
-