aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/clutter/clutter-1.0.inc
diff options
context:
space:
mode:
authorTomas Frydrych <tomas@sleepfive.com>2013-05-20 16:05:21 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-05-21 09:14:37 +0100
commit4fbae4449fbb3f5eba499418b374c12bccfb4243 (patch)
tree8cb6ea5ceea62218fe73f0bbc39b19505f932d4f /meta/recipes-graphics/clutter/clutter-1.0.inc
parentb508fdd2b19ca30da8d09caf646897dc4cf195c8 (diff)
downloadopenembedded-core-contrib-4fbae4449fbb3f5eba499418b374c12bccfb4243.tar.gz
clutter: Replace with 1.14.4 version
The package has been renamed to clutter-1.0 instead of clutter-vmajor.vminor, keeping up with the upstream versioning policy (all 1.x packages install clutter-1.0 pc file and headers and are backward compatible), and to simplify dependency management (worth noting that since the 1.x development files are not parall installable, it is not possible to use two versions of clutter 1.x at the same time anyway). Package configuration is provided via PACKAGECONFIG options as follows: 'x11' : enable X11 backend, 'glx' : enable GLX backend, 'egl' : enable EGL backend, 'evdev': enable evdev input backend Default configuration is 'glx'; typical configuration for embedded HW using 'native' EGL would be 'egl evdev'. Signed-off-by: Tomas Frydrych <tomas@sleepfive.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/clutter/clutter-1.0.inc')
-rw-r--r--meta/recipes-graphics/clutter/clutter-1.0.inc56
1 files changed, 56 insertions, 0 deletions
diff --git a/meta/recipes-graphics/clutter/clutter-1.0.inc b/meta/recipes-graphics/clutter/clutter-1.0.inc
new file mode 100644
index 0000000000..6710776213
--- /dev/null
+++ b/meta/recipes-graphics/clutter/clutter-1.0.inc
@@ -0,0 +1,56 @@
+DESCRIPTION = "Clutter graphics library"
+HOMEPAGE = "http://www.clutter-project.org/"
+LICENSE = "LGPLv2.1+"
+
+inherit clutter
+
+SRC_URI += "file://enable_tests.patch"
+
+DEPENDS = "gtk-doc-native pango glib-2.0 json-glib atk udev cogl-1.0"
+PACKAGES =+ "${PN}-examples"
+AUTOTOOLS_AUXDIR = "${S}/build"
+
+EDEPENDS_X11 = "virtual/libx11 libxi libxfixes"
+EDEPENDS_GLX = "virtual/libgl"
+EDEPENDS_EGL = "virtual/egl"
+
+EDEPENDS_EVDEV = "libxkbcommon"
+ERDEPENDS_EVDEV = "xkeyboard-config"
+
+# Disable pretty much everything, override in platform specific set up
+EXTRA_OECONF += "--disable-gtk-doc \
+ ${@get_fpu_setting(bb, d)} \
+ --disable-introspection \
+ --disable-egl-backend \
+ --disable-quartz-backend \
+ --disable-win32-backend \
+ --disable-x11-backend \
+ --disable-gdk-backend \
+ --disable-wayland-backend \
+ --disable-wayland-compositor \
+ --disable-cex100-backend \
+ --disable-tslib-input \
+ --disable-evdev-input \
+ "
+
+PACKAGECONFIG[x11] = "--enable-x11-backend,,${EDEPENDS_X11}"
+PACKAGECONFIG[glx] = "--enable-x11-backend,,${EDEPENDS_X11} ${EDEPENDS_GLX}"
+PACKAGECONFIG[egl] = "--enable-egl-backend,,${EDEPENDS_EGL}"
+PACKAGECONFIG[evdev] = "--enable-evdev-input,,${EDEPENDS_EVDEV},${ERDEPENDS_EVDEV}"
+
+# Default configuration, distros might want to override
+PACKAGECONFIG ??= "glx"
+
+FILES_${PN}-examples = "${bindir}/test-* ${pkgdatadir}/redhand.png"
+
+do_configure_prepend() {
+ # Fix up some weirdness in the docs
+ sed -i s:doc/reference/Makefile::g ${S}/configure.ac
+ sed -i s:doc::g ${S}/Makefile.am
+
+ # see https://bugzilla.gnome.org/show_bug.cgi?id=661128 for this
+ touch -t 200001010000 po/clutter-1.0.pot
+
+ # Disable DOLT
+ sed -i -e 's/^DOLT//' ${S}/configure.ac
+}