aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/cairo/cairo_1.14.4.bb
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2015-11-06 00:52:27 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-11-16 11:37:22 +0000
commitff340f200159f79c0265234af58f965ae21a2965 (patch)
tree1ae389e4cc19171bd590b1bec9da54146398e74b /meta/recipes-graphics/cairo/cairo_1.14.4.bb
parentcedc94919995473ba67968a9115023d6061ab045 (diff)
downloadopenembedded-core-contrib-ff340f200159f79c0265234af58f965ae21a2965.tar.gz
cairo: update 1.14.2 -> 1.14.4
Release 1.14.4 (2015-10-28 Bryce Harrington <bryce@osg.samsung.com>) ======================================================================== Just in time for Halloween we see another bug-fix release for Cairo. This brings a few dozen straightforward bug fixes with no API changes. In addition, this includes a typical assortment of fixes to tests, cleanup of warnings and memory leaks, correction of misspellings, updates to documentation, etc. For a complete log of changes since 1.14.2, please see: http://cairographics.org/releases/ChangeLog.cairo-1.14.4 Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics/cairo/cairo_1.14.4.bb')
-rw-r--r--meta/recipes-graphics/cairo/cairo_1.14.4.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-graphics/cairo/cairo_1.14.4.bb b/meta/recipes-graphics/cairo/cairo_1.14.4.bb
new file mode 100644
index 0000000000..17ea851c9f
--- /dev/null
+++ b/meta/recipes-graphics/cairo/cairo_1.14.4.bb
@@ -0,0 +1,43 @@
+require cairo.inc
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=e73e999e0c72b5ac9012424fa157ad77"
+
+SRC_URI = "http://cairographics.org/releases/cairo-${PV}.tar.xz"
+
+SRC_URI[md5sum] = "90a929e8fe66fb5d19b5adaaea1e9a12"
+SRC_URI[sha256sum] = "f6ec9c7c844db9ec011f0d66b57ef590c45adf55393d1fc249003512522ee716"
+
+PACKAGES =+ "cairo-gobject cairo-script-interpreter cairo-perf-utils"
+
+SUMMARY_${PN} = "The Cairo 2D vector graphics library"
+DESCRIPTION_${PN} = "Cairo is a multi-platform library providing anti-aliased \
+vector-based rendering for multiple target backends. Paths consist \
+of line segments and cubic splines and can be rendered at any width \
+with various join and cap styles. All colors may be specified with \
+optional translucence (opacity/alpha) and combined using the \
+extended Porter/Duff compositing algebra as found in the X Render \
+Extension."
+
+SUMMARY_cairo-gobject = "The Cairo library GObject wrapper library"
+DESCRIPTION_cairo-gobject = "A GObject wrapper library for the Cairo API."
+
+SUMMARY_cairo-script-interpreter = "The Cairo library script interpreter"
+DESCRIPTION_cairo-script-interpreter = "The Cairo script interpreter implements \
+CairoScript. CairoScript is used by tracing utilities to enable the ability \
+to replay rendering."
+
+DESCRIPTION_cairo-perf-utils = "The Cairo library performance utilities"
+
+FILES_${PN} = "${libdir}/libcairo.so.*"
+FILES_${PN}-dev += "${libdir}/cairo/*.so"
+FILES_${PN}-gobject = "${libdir}/libcairo-gobject.so.*"
+FILES_${PN}-script-interpreter = "${libdir}/libcairo-script-interpreter.so.*"
+FILES_${PN}-perf-utils = "${bindir}/cairo-trace ${libdir}/cairo/*.la ${libdir}/cairo/libcairo-trace.so.*"
+
+do_install_append () {
+ rm -rf ${D}${bindir}/cairo-sphinx
+ rm -rf ${D}${libdir}/cairo/cairo-fdr*
+ rm -rf ${D}${libdir}/cairo/cairo-sphinx*
+ rm -rf ${D}${libdir}/cairo/.debug/cairo-fdr*
+ rm -rf ${D}${libdir}/cairo/.debug/cairo-sphinx*
+}