aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-14 22:21:37 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-14 23:04:03 +0000
commit3ba6cee84de89f8eb200e4c93d446f6cdeeaa4be (patch)
treee59512dcf373b7374ac78d3a8d4610c4177dbbff /meta/recipes-gnome
parent4b1c0c7d5525fc4cea9e0f02ec54e92a6fbc6199 (diff)
downloadopenembedded-core-contrib-3ba6cee84de89f8eb200e4c93d446f6cdeeaa4be.tar.gz
meta: Fix python code quoting issues
python 3.8 will be stricter about python quoting. Fix up several misquoted expressions and fix Deprecation warnings like: Var <do_compile>:1: DeprecationWarning: invalid escape sequence \$ Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-gnome')
-rw-r--r--meta/recipes-gnome/gobject-introspection/gobject-introspection_1.58.2.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-gnome/gobject-introspection/gobject-introspection_1.58.2.bb b/meta/recipes-gnome/gobject-introspection/gobject-introspection_1.58.2.bb
index 242899accc..d00f3bd344 100644
--- a/meta/recipes-gnome/gobject-introspection/gobject-introspection_1.58.2.bb
+++ b/meta/recipes-gnome/gobject-introspection/gobject-introspection_1.58.2.bb
@@ -76,7 +76,7 @@ do_configure_prepend_class-native() {
do_configure_prepend_class-target() {
# Write out a qemu wrapper that will be given to gi-scanner so that it
# can run target helper binaries through that.
- qemu_binary="${@qemu_wrapper_cmdline(d, '$STAGING_DIR_HOST', ['\$GIR_EXTRA_LIBS_PATH','.libs','$STAGING_DIR_HOST/${libdir}','$STAGING_DIR_HOST/${base_libdir}'])}"
+ qemu_binary="${@qemu_wrapper_cmdline(d, '$STAGING_DIR_HOST', ['\\$GIR_EXTRA_LIBS_PATH','.libs','$STAGING_DIR_HOST/${libdir}','$STAGING_DIR_HOST/${base_libdir}'])}"
cat > ${B}/g-ir-scanner-qemuwrapper << EOF
#!/bin/sh
# Use a modules directory which doesn't exist so we don't load random things