summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2022-12-20 12:55:41 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-12-21 10:16:25 +0000
commitb525fab08cb4f6d7b9a71bf82378a8396a20aba8 (patch)
tree74f35b07dd8f0b3ec57add42a7b90b56a97cee6f /meta/recipes-gnome
parent6cb38fd632a161bea7b9a04de400d8be8d565b07 (diff)
downloadopenembedded-core-contrib-b525fab08cb4f6d7b9a71bf82378a8396a20aba8.tar.gz
gtk+3: fix reproducible builds
We can't drop the missing meson.build file into the build tree via SRC_URI as then the timestamp of that file becomes the timestamp of the build, which results in repeated builds having different timestamps. Instead patch the file into the build, which doesn't change the SDE every build. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-gnome')
-rw-r--r--meta/recipes-gnome/gtk+/gtk+3/add-missing-meson.build.patch38
-rw-r--r--meta/recipes-gnome/gtk+/gtk+3/meson.build14
-rw-r--r--meta/recipes-gnome/gtk+/gtk+3_3.24.35.bb2
3 files changed, 39 insertions, 15 deletions
diff --git a/meta/recipes-gnome/gtk+/gtk+3/add-missing-meson.build.patch b/meta/recipes-gnome/gtk+/gtk+3/add-missing-meson.build.patch
new file mode 100644
index 0000000000..ef971ccff4
--- /dev/null
+++ b/meta/recipes-gnome/gtk+/gtk+3/add-missing-meson.build.patch
@@ -0,0 +1,38 @@
+From 8a00d0269d547799b598adda364ad6c6ee328e6b Mon Sep 17 00:00:00 2001
+From: Ross Burton <ross.burton@arm.com>
+Date: Tue, 20 Dec 2022 12:09:07 +0000
+Subject: [PATCH] Add missing meson.build
+
+This file was missing from the tarball, but will be in the .36 release.
+
+Upstream-Status: Inappropriate
+Signed-off-by: Ross Burton <ross.burton@arm.com>
+
+---
+ gdk/wayland/cursor/meson.build | 14 ++++++++++++++
+ 1 file changed, 14 insertions(+)
+ create mode 100644 gdk/wayland/cursor/meson.build
+
+diff --git a/gdk/wayland/cursor/meson.build b/gdk/wayland/cursor/meson.build
+new file mode 100644
+index 0000000..94cf47a
+--- /dev/null
++++ b/gdk/wayland/cursor/meson.build
+@@ -0,0 +1,14 @@
++# This file is missing from the 3.24.35 tarball
++
++wayland_cursor_sources = files([
++ 'wayland-cursor.c',
++ 'xcursor.c',
++ 'os-compatibility.c'
++])
++
++libwayland_cursor = static_library('wayland+cursor',
++ sources: wayland_cursor_sources,
++ include_directories: [ confinc, ],
++ dependencies: [ glib_dep, wlclientdep, ],
++ c_args: common_cflags,
++)
+--
+2.34.1
+
diff --git a/meta/recipes-gnome/gtk+/gtk+3/meson.build b/meta/recipes-gnome/gtk+/gtk+3/meson.build
deleted file mode 100644
index 94cf47a37f..0000000000
--- a/meta/recipes-gnome/gtk+/gtk+3/meson.build
+++ /dev/null
@@ -1,14 +0,0 @@
-# This file is missing from the 3.24.35 tarball
-
-wayland_cursor_sources = files([
- 'wayland-cursor.c',
- 'xcursor.c',
- 'os-compatibility.c'
-])
-
-libwayland_cursor = static_library('wayland+cursor',
- sources: wayland_cursor_sources,
- include_directories: [ confinc, ],
- dependencies: [ glib_dep, wlclientdep, ],
- c_args: common_cflags,
-)
diff --git a/meta/recipes-gnome/gtk+/gtk+3_3.24.35.bb b/meta/recipes-gnome/gtk+/gtk+3_3.24.35.bb
index 7c6ea104c7..a467c0e9e9 100644
--- a/meta/recipes-gnome/gtk+/gtk+3_3.24.35.bb
+++ b/meta/recipes-gnome/gtk+/gtk+3_3.24.35.bb
@@ -3,7 +3,7 @@ require gtk+3.inc
MAJ_VER = "${@oe.utils.trim_version("${PV}", 2)}"
SRC_URI = "http://ftp.gnome.org/pub/gnome/sources/gtk+/${MAJ_VER}/gtk+-${PV}.tar.xz \
- file://meson.build;subdir=${S}/gdk/wayland/cursor \
+ file://add-missing-meson.build.patch \
file://buildpaths.patch \
file://opengl.patch \
"