summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome
diff options
context:
space:
mode:
authorCarlos Alberto Lopez Perez <clopez@igalia.com>2022-12-20 04:56:50 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-12-21 10:16:25 +0000
commit6cb38fd632a161bea7b9a04de400d8be8d565b07 (patch)
tree2395e58003b20072c89981532799465838a74722 /meta/recipes-gnome
parent68c391f50a753a51c99a10fdffd6f35c516f2873 (diff)
downloadopenembedded-core-contrib-6cb38fd632a161bea7b9a04de400d8be8d565b07.tar.gz
recipes: Enable nativesdk for gperf, unifdef, gi-docgen and its dependencies
I'm building a SDK (bitbake task: populate_sdk) for WPE/WebKit development [1] and I need the tools below to be extended with the class nativesdk. They work fine on the SDK after this change. The needs are because: 1) gperf and unifdef are required by the WebKit build system at build time. 2) gi-docgen is required by the WebKit build system when CMake option 'ENABLE_DOCUMENTATION' is enabled, and gi-docgen itself depends on the following python modules that also need to enable nativesdk: python3-markdown, python3-smartypants and python3-typogrify [1] See: - https://github.com/Igalia/meta-webkit/pull/436 - https://bugs.webkit.org/show_bug.cgi?id=249604 Signed-off-by: Carlos Alberto Lopez Perez <clopez@igalia.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-gnome')
-rw-r--r--meta/recipes-gnome/gi-docgen/gi-docgen_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-gnome/gi-docgen/gi-docgen_git.bb b/meta/recipes-gnome/gi-docgen/gi-docgen_git.bb
index 9e5adca3df..fa41f2ccd2 100644
--- a/meta/recipes-gnome/gi-docgen/gi-docgen_git.bb
+++ b/meta/recipes-gnome/gi-docgen/gi-docgen_git.bb
@@ -19,4 +19,4 @@ inherit setuptools3
RDEPENDS:${PN} += "python3-asyncio python3-core python3-jinja2 python3-json python3-markdown python3-markupsafe python3-pygments python3-toml python3-typogrify python3-xml"
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"