summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-02-19 20:47:48 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-02-21 09:37:04 +0000
commit66885ec7ac3a1ed978f64b148e209ea132aca6b2 (patch)
tree592eec6f35e9f080ffe0e759263c280050cf43ef /meta/recipes-gnome
parent2c492e3310ffe8078e63ae37cc94bb5e193ffc74 (diff)
downloadopenembedded-core-contrib-66885ec7ac3a1ed978f64b148e209ea132aca6b2.tar.gz
libsecret: upgrade 0.20.0 -> 0.20.1
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-gnome')
-rw-r--r--meta/recipes-gnome/libsecret/libsecret/0001-secret-file-collection-Rename-internal-functions-to-.patch144
-rw-r--r--meta/recipes-gnome/libsecret/libsecret_0.20.1.bb (renamed from meta/recipes-gnome/libsecret/libsecret_0.20.0.bb)5
2 files changed, 2 insertions, 147 deletions
diff --git a/meta/recipes-gnome/libsecret/libsecret/0001-secret-file-collection-Rename-internal-functions-to-.patch b/meta/recipes-gnome/libsecret/libsecret/0001-secret-file-collection-Rename-internal-functions-to-.patch
deleted file mode 100644
index 269c12b010..0000000000
--- a/meta/recipes-gnome/libsecret/libsecret/0001-secret-file-collection-Rename-internal-functions-to-.patch
+++ /dev/null
@@ -1,144 +0,0 @@
-From 59bcb169c4777bb3b1a50fee2ae20e4e8574b749 Mon Sep 17 00:00:00 2001
-From: Daiki Ueno <dueno@src.gnome.org>
-Date: Tue, 14 Jan 2020 10:09:29 +0100
-Subject: [PATCH] secret-file-collection: Rename internal functions to avoid
- conflicts
-
-As encrypt() is a standard POSIX function, its declaration had
-conflict with our own. Let's be more verbose about naming of the
-internal crypto functions.
-
-Fixes #35.
-
-Upstream-Status: Backport [https://github.com/GNOME/libsecret/commit/cf21ad50b62f7c8e4b22ef374f0a73290a99bdb8]
-Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
----
- libsecret/secret-file-collection.c | 38 +++++++++++++++---------------
- 1 file changed, 19 insertions(+), 19 deletions(-)
-
-diff --git a/libsecret/secret-file-collection.c b/libsecret/secret-file-collection.c
-index 79863ea..8ffb542 100644
---- a/libsecret/secret-file-collection.c
-+++ b/libsecret/secret-file-collection.c
-@@ -68,7 +68,7 @@ enum {
- };
-
- static gboolean
--derive (SecretFileCollection *self)
-+do_derive_key (SecretFileCollection *self)
- {
- const gchar *password;
- gsize n_password;
-@@ -93,9 +93,9 @@ derive (SecretFileCollection *self)
- }
-
- static gboolean
--calculate_mac (SecretFileCollection *self,
-- const guint8 *value, gsize n_value,
-- guint8 *buffer)
-+do_calculate_mac (SecretFileCollection *self,
-+ const guint8 *value, gsize n_value,
-+ guint8 *buffer)
- {
- gcry_mac_hd_t hd;
- gcry_error_t gcry;
-@@ -130,9 +130,9 @@ calculate_mac (SecretFileCollection *self,
- }
-
- static gboolean
--decrypt (SecretFileCollection *self,
-- guint8 *data,
-- gsize n_data)
-+do_decrypt (SecretFileCollection *self,
-+ guint8 *data,
-+ gsize n_data)
- {
- gcry_cipher_hd_t hd;
- gcry_error_t gcry;
-@@ -164,9 +164,9 @@ decrypt (SecretFileCollection *self,
- }
-
- static gboolean
--encrypt (SecretFileCollection *self,
-- guint8 *data,
-- gsize n_data)
-+do_encrypt (SecretFileCollection *self,
-+ guint8 *data,
-+ gsize n_data)
- {
- gcry_cipher_hd_t hd;
- gcry_error_t gcry;
-@@ -311,7 +311,7 @@ on_load_contents (GObject *source_object,
- self->modified = g_date_time_new_now_utc ();
- self->usage_count = 0;
-
-- if (!derive (self)) {
-+ if (!do_derive_key (self)) {
- g_task_return_new_error (task,
- SECRET_ERROR,
- SECRET_ERROR_PROTOCOL,
-@@ -375,7 +375,7 @@ on_load_contents (GObject *source_object,
- g_assert (n_data == salt_size);
-
- self->salt = g_bytes_new (data, n_data);
-- if (!derive (self)) {
-+ if (!do_derive_key (self)) {
- g_task_return_new_error (task,
- SECRET_ERROR,
- SECRET_ERROR_PROTOCOL,
-@@ -442,7 +442,7 @@ hash_attributes (SecretFileCollection *self,
- GVariant *variant;
-
- value = g_hash_table_lookup (attributes, l->data);
-- if (!calculate_mac (self, (guint8 *)value, strlen (value), buffer)) {
-+ if (!do_calculate_mac (self, (guint8 *)value, strlen (value), buffer)) {
- g_list_free (keys);
- return NULL;
- }
-@@ -485,7 +485,7 @@ hashed_attributes_match (SecretFileCollection *self,
- return FALSE;
- }
-
-- if (!calculate_mac (self, value, strlen ((char *)value), buffer)) {
-+ if (!do_calculate_mac (self, value, strlen ((char *)value), buffer)) {
- g_variant_unref (hashed_attribute);
- return FALSE;
- }
-@@ -584,7 +584,7 @@ secret_file_collection_replace (SecretFileCollection *self,
- g_variant_store (serialized_item, data);
- g_variant_unref (serialized_item);
- memset (data + n_data, n_padded - n_data, n_padded - n_data);
-- if (!encrypt (self, data, n_padded)) {
-+ if (!do_encrypt (self, data, n_padded)) {
- egg_secure_free (data);
- g_set_error (error,
- SECRET_ERROR,
-@@ -593,8 +593,8 @@ secret_file_collection_replace (SecretFileCollection *self,
- return FALSE;
- }
-
-- if (!calculate_mac (self, data, n_padded + IV_SIZE,
-- data + n_padded + IV_SIZE)) {
-+ if (!do_calculate_mac (self, data, n_padded + IV_SIZE,
-+ data + n_padded + IV_SIZE)) {
- egg_secure_free (data);
- g_set_error (error,
- SECRET_ERROR,
-@@ -681,7 +681,7 @@ _secret_file_item_decrypt (GVariant *encrypted,
- }
- n_padded -= IV_SIZE + MAC_SIZE;
-
-- if (!calculate_mac (collection, data, n_padded + IV_SIZE, mac)) {
-+ if (!do_calculate_mac (collection, data, n_padded + IV_SIZE, mac)) {
- egg_secure_free (data);
- g_set_error (error,
- SECRET_ERROR,
-@@ -699,7 +699,7 @@ _secret_file_item_decrypt (GVariant *encrypted,
- return FALSE;
- }
-
-- if (!decrypt (collection, data, n_padded)) {
-+ if (!do_decrypt (collection, data, n_padded)) {
- egg_secure_free (data);
- g_set_error (error,
- SECRET_ERROR,
diff --git a/meta/recipes-gnome/libsecret/libsecret_0.20.0.bb b/meta/recipes-gnome/libsecret/libsecret_0.20.1.bb
index aa3dfab581..72511af02d 100644
--- a/meta/recipes-gnome/libsecret/libsecret_0.20.0.bb
+++ b/meta/recipes-gnome/libsecret/libsecret_0.20.1.bb
@@ -13,9 +13,8 @@ DEPENDS += "glib-2.0 libgcrypt gettext-native"
PACKAGECONFIG[manpages] = "--enable-manpages, --disable-manpages, libxslt-native xmlto-native"
-SRC_URI += " file://0001-secret-file-collection-Rename-internal-functions-to-.patch"
-SRC_URI[archive.md5sum] = "335750caeed47f50496b3b0e6a1875ff"
-SRC_URI[archive.sha256sum] = "f1187370b453106af878e30c284a121ba0c513da8bb4170b329d66e250bdae43"
+SRC_URI[archive.md5sum] = "d2dd660a8d502099317bc8af9f30302e"
+SRC_URI[archive.sha256sum] = "57f73e94ec6263a17a077fb809cf8cf424637a897a7f15b4eec42ce4aef52447"
# http://errors.yoctoproject.org/Errors/Details/20228/
ARM_INSTRUCTION_SET_armv4 = "arm"