summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-21 18:14:31 +0100
committerArmin Kuster <akuster808@gmail.com>2019-06-02 10:25:35 -0700
commit3f5f91a2a1f3ebb8151834ce4223dcd33f363803 (patch)
tree4f22dd3ec80e0562155352f39d18336124389fe0 /meta/recipes-extended
parentd2361e9bb6caf66cf6d492fc5957c601fd3f9e6d (diff)
downloadopenembedded-core-contrib-3f5f91a2a1f3ebb8151834ce4223dcd33f363803.tar.gz
perl/modules: Add various missing ptest perl module dependencies
Whilst not complete, this resolves some module dependency failures being seen by various lib*-perl ptests and in quilt. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/perl/libtimedate-perl_2.30.bb1
-rw-r--r--meta/recipes-extended/perl/libxml-sax-base-perl_1.09.bb2
-rw-r--r--meta/recipes-extended/perl/libxml-sax-perl_1.00.bb2
3 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-extended/perl/libtimedate-perl_2.30.bb b/meta/recipes-extended/perl/libtimedate-perl_2.30.bb
index 8e1461ceb9..7129c647cb 100644
--- a/meta/recipes-extended/perl/libtimedate-perl_2.30.bb
+++ b/meta/recipes-extended/perl/libtimedate-perl_2.30.bb
@@ -15,6 +15,7 @@ BBCLASSEXTEND = "native"
RDEPENDS_${PN}_class-native = ""
RDEPENDS_${PN} += "perl-module-carp perl-module-exporter perl-module-strict perl-module-time-local"
+RDEPENDS_${PN}-ptest += "perl-module-test-more"
SRC_URI[md5sum] = "b1d91153ac971347aee84292ed886c1c"
SRC_URI[sha256sum] = "75bd254871cb5853a6aa0403ac0be270cdd75c9d1b6639f18ecba63c15298e86"
diff --git a/meta/recipes-extended/perl/libxml-sax-base-perl_1.09.bb b/meta/recipes-extended/perl/libxml-sax-base-perl_1.09.bb
index 373b522d6a..2bff65a082 100644
--- a/meta/recipes-extended/perl/libxml-sax-base-perl_1.09.bb
+++ b/meta/recipes-extended/perl/libxml-sax-base-perl_1.09.bb
@@ -21,4 +21,6 @@ S = "${WORKDIR}/XML-SAX-Base-${PV}"
inherit cpan ptest-perl
+RDEPENDS_${PN}-ptest += "perl-module-test perl-module-test-more"
+
BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-extended/perl/libxml-sax-perl_1.00.bb b/meta/recipes-extended/perl/libxml-sax-perl_1.00.bb
index eccd0ad6b4..fd3a2a0ee7 100644
--- a/meta/recipes-extended/perl/libxml-sax-perl_1.00.bb
+++ b/meta/recipes-extended/perl/libxml-sax-perl_1.00.bb
@@ -29,4 +29,6 @@ do_install_ptest() {
chown -R root:root ${D}${PTEST_PATH}/testfiles
}
+RDEPENDS_${PN}-ptest += "perl-module-test"
+
BBCLASSEXTEND = "native nativesdk"