aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorChunrong Guo <B40290@freescale.com>2013-11-12 11:40:49 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-12-12 16:53:09 +0000
commitc5e59e68efcf2a3f902dbfd827da57ed3e8ad4ce (patch)
tree2ffaf2eb0cc695377df22d1d733c6f7ae51b8a8d /meta/recipes-extended
parenta51d96c44e6feac8322284c54bfc01ef598f8821 (diff)
downloadopenembedded-core-contrib-c5e59e68efcf2a3f902dbfd827da57ed3e8ad4ce.tar.gz
mdadm: flag __SANE_USERSPACE_TYPES__ to include int-ll64.h for powerpc64
*PPC64 uses long long for u64 in the kernel, but powerpc's asm/types.h prevents 64-bit userland from seeing this definition, instead defaulting to u64 == long in userspace. *fix the below error |super-ddf.c:4542:5: error: format '%llu' expects argument of type 'long long unsigned int', |but argument 5 has type '__u64' [-Werror=format=] |dprintf("BVD %u has %08x at %llu\n", 0, (From OE-Core master rev: d3caab6eb03264b4f4d744f914598022299011ba) Signed-off-by: Chunrong Guo <B40290@freescale.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/mdadm/mdadm_3.2.6.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-extended/mdadm/mdadm_3.2.6.bb b/meta/recipes-extended/mdadm/mdadm_3.2.6.bb
index 50f39dbc0d..382c0c128a 100644
--- a/meta/recipes-extended/mdadm/mdadm_3.2.6.bb
+++ b/meta/recipes-extended/mdadm/mdadm_3.2.6.bb
@@ -27,6 +27,11 @@ do_configure_prepend () {
}
EXTRA_OEMAKE = "CHECK_RUN_DIR=0"
+# PPC64 uses long long for u64 in the kernel, but powerpc's asm/types.h
+# prevents 64-bit userland from seeing this definition, instead defaulting
+# to u64 == long in userspace. Define __SANE_USERSPACE_TYPES__ to get
+# int-ll64.h included
+EXTRA_OEMAKE_append_powerpc64 = ' CFLAGS=-D__SANE_USERSPACE_TYPES__'
do_compile() {
oe_runmake