aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2018-06-13 15:58:21 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-06-18 10:59:33 +0100
commit183c9125e78ae1035894600a66b4ea1fa6a3a532 (patch)
tree49ffd4ddd0c4e2ff15148e7bb4a820c5fe6f4495 /meta/recipes-extended
parent80638247143b15a5643f9fcc116d7bc7dcbf3496 (diff)
downloadopenembedded-core-contrib-183c9125e78ae1035894600a66b4ea1fa6a3a532.tar.gz
watchdog: disable systemd services by default
systemd has internal support for watchdog. See the RuntimeWatchdogSec in /etc/systemd/system.conf. We'd better just disable this service by default. If users want to use watchdog, consider using the systemd one. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/watchdog/watchdog_5.15.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-extended/watchdog/watchdog_5.15.bb b/meta/recipes-extended/watchdog/watchdog_5.15.bb
index d3f03532ac..bfaed9ad96 100644
--- a/meta/recipes-extended/watchdog/watchdog_5.15.bb
+++ b/meta/recipes-extended/watchdog/watchdog_5.15.bb
@@ -40,6 +40,9 @@ INITSCRIPT_PARAMS_${PN}-keepalive = "start 15 1 2 3 4 5 . stop 85 0 6 ."
SYSTEMD_PACKAGES = "${PN} ${PN}-keepalive"
SYSTEMD_SERVICE_${PN} = "watchdog.service"
SYSTEMD_SERVICE_${PN}-keepalive = "wd_keepalive.service"
+# When using systemd, consider making use of internal watchdog support of systemd.
+# See RuntimeWatchdogSec in /etc/systemd/system.conf.
+SYSTEMD_AUTO_ENABLE = "disable"
do_install_append() {
install -d ${D}${systemd_system_unitdir}