summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2019-02-26 12:10:35 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-02-27 18:03:44 +0000
commit692d5b1025450bf1c33fb6aa041603f082e2ba4d (patch)
tree6c611b4f566c02eb7f07cd08aba6874bdb9d6321 /meta/recipes-extended
parente6f1d15e307a8d2f5f05c9ec9dd8163e9072ad07 (diff)
downloadopenembedded-core-contrib-692d5b1025450bf1c33fb6aa041603f082e2ba4d.tar.gz
cpio: avoid conflict with tar-doc and rmt.8
This fixes: Error: Transaction check error: file /usr/share/man/man8/rmt.8 conflicts between attempted installs of cpio-doc-2.12-r0.core2_64 and tar-doc-1.31-r0.core2_64 Prior to commit 348a96a5b401 [tar: upgrade to 1.31] the copies of rmt.8 found in the tar(-doc) and cpio(-doc) packages were the same and thus no conflict was seen. After the upgrade there were small changes in the manpage header which results in the conflict quoted above. The applications themselves make use of the 'update-alternatives' mechanism to allow a user to select which version of 'rmt' to use but since the man pages are essentially the same we disambiguate the source of the man pages and make them both available should both cpio-doc and tar-doc are both installed. And as such we avoid the conflict. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/cpio/cpio_2.12.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-extended/cpio/cpio_2.12.bb b/meta/recipes-extended/cpio/cpio_2.12.bb
index 6ba8337e5d..cb845c3070 100644
--- a/meta/recipes-extended/cpio/cpio_2.12.bb
+++ b/meta/recipes-extended/cpio/cpio_2.12.bb
@@ -27,6 +27,9 @@ do_install () {
mv "${D}${bindir}/cpio" "${D}${base_bindir}/cpio"
rmdir ${D}${bindir}/
fi
+
+ # Avoid conflicts with the version from tar
+ mv "${D}${mandir}/man8/rmt.8" "${D}${mandir}/man8/rmt-cpio.8"
}
PACKAGES =+ "${PN}-rmt"