summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-12-14 10:10:40 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-18 22:52:13 +0000
commit483ca253cc25f928759263f9f3f2b3699e82252b (patch)
tree7c5f6f0673a8acc10dc602f2b7ca7f494107ae23 /meta/recipes-extended
parent7f7d2fa18267090891754d976cbc3e628324d3dd (diff)
downloadopenembedded-core-contrib-483ca253cc25f928759263f9f3f2b3699e82252b.tar.gz
bzip2: run ptests without valgrind
Otherwise, valgrind significantly slows them down, and actually even causes ptest timeouts on arm64. Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/bzip2/bzip2/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-extended/bzip2/bzip2/Makefile.am b/meta/recipes-extended/bzip2/bzip2/Makefile.am
index d4498947e8..7338df03eb 100644
--- a/meta/recipes-extended/bzip2/bzip2/Makefile.am
+++ b/meta/recipes-extended/bzip2/bzip2/Makefile.am
@@ -46,7 +46,7 @@ runtest:
else echo "FAIL: sample2 decompress"; fi
@if cmp sample3.tst sample3.ref; then echo "PASS: sample3 decompress";\
else echo "FAIL: sample3 decompress"; fi
- ./bzip2-tests/run-tests.sh --tests-dir="$(PWD)/bzip2-tests"
+ ./bzip2-tests/run-tests.sh --without-valgrind --tests-dir="$(PWD)/bzip2-tests"
install-ptest:
sed -n '/^runtest:/,/^install-ptest:/{/^install-ptest:/!p}' \