aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorSteffen Sledz <sledz@dresearch-fe.de>2014-02-11 09:59:31 +0100
committerAndreas Oberritter <obi@opendreambox.org>2015-02-23 17:15:23 +0100
commitca8a24315eb41de5a4bda42e3f5496eb83d247f1 (patch)
tree513cb7f8ecbc53fc1b7f2605139afa34e461f011 /meta/recipes-extended
parent75433f77f063346e95ed3927984e5ece33924910 (diff)
downloadopenembedded-core-contrib-ca8a24315eb41de5a4bda42e3f5496eb83d247f1.tar.gz
lighttpd: introduce /etc/lighttpd.d subdir for config file includes
Extend default config file by a directive to include config file fragments from /etc/lighttpd.d. This allows other web application packages to put their configuration there. Signed-off-by: Steffen Sledz <sledz@dresearch-fe.de> Signed-off-by: Saul Wold <sgw@linux.intel.com> (cherry picked from commit 949ef58cf0684147b07745bd1199014ac57b437c) Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/lighttpd/lighttpd/lighttpd.conf3
-rw-r--r--meta/recipes-extended/lighttpd/lighttpd_1.4.33.bb3
2 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-extended/lighttpd/lighttpd/lighttpd.conf b/meta/recipes-extended/lighttpd/lighttpd/lighttpd.conf
index 3342470cec..6e8402d242 100644
--- a/meta/recipes-extended/lighttpd/lighttpd/lighttpd.conf
+++ b/meta/recipes-extended/lighttpd/lighttpd/lighttpd.conf
@@ -326,3 +326,6 @@ static-file.exclude-extensions = ( ".php", ".pl", ".fcgi" )
#include_shell "echo var.a=1"
## the above is same as:
#var.a=1
+
+# include other config file fragments from lighttpd.d subdir
+include_shell "find /etc/lighttpd.d -maxdepth 1 -name '*.conf' -exec cat {} \;"
diff --git a/meta/recipes-extended/lighttpd/lighttpd_1.4.33.bb b/meta/recipes-extended/lighttpd/lighttpd_1.4.33.bb
index c53d6772bb..d826ff9d42 100644
--- a/meta/recipes-extended/lighttpd/lighttpd_1.4.33.bb
+++ b/meta/recipes-extended/lighttpd/lighttpd_1.4.33.bb
@@ -5,6 +5,7 @@ BUGTRACKER = "http://redmine.lighttpd.net/projects/lighttpd/issues"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=e4dac5c6ab169aa212feb5028853a579"
+PR = "r1"
SECTION = "net"
DEPENDS = "zlib libpcre"
@@ -48,7 +49,7 @@ INITSCRIPT_PARAMS = "defaults 70"
SYSTEMD_SERVICE_${PN} = "lighttpd.service"
do_install_append() {
- install -d ${D}${sysconfdir}/init.d ${D}/www/pages/dav
+ install -d ${D}${sysconfdir}/init.d ${D}${sysconfdir}/lighttpd.d ${D}/www/pages/dav
install -m 0755 ${WORKDIR}/lighttpd ${D}${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/lighttpd.conf ${D}${sysconfdir}
install -m 0644 ${WORKDIR}/index.html.lighttpd ${D}/www/pages/index.html