aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2013-12-07 18:49:42 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-24 12:48:15 +0000
commit198623d80d31f19c963e61d03cbcb12dd318dfdf (patch)
tree8cf49585acd4652cbafd38cbea98b8b0cb61e2ca /meta/recipes-extended
parente64d2a6d408ac542bdaa42680d10d0fb05b92a60 (diff)
downloadopenembedded-core-contrib-198623d80d31f19c963e61d03cbcb12dd318dfdf.tar.gz
ltp: set PREFERRED_PROVIDER and rename runtests_noltp.sh script
* ltp installs 2 different runtests_noltp.sh files from different directories into /opt/ltp/testcases/bin/runtests_noltp.sh last one installed wins and causes unexpected changes in buildhistory's files-in-image.txt report, rename them to have unique name as other ltp scripts have. * also define PREFERRED_PROVIDER to resolve note shown when building with meta-oe layer: NOTE: multiple providers are available for ltp (ltp, ltp-ddt) NOTE: consider defining a PREFERRED_PROVIDER entry to match ltp * use patch generated without -M in my builds both versions worked, but Saul reported that it fails to apply with: Applying patch 0001-Rename-runtests_noltp.sh-script-so-have-unique-name.patch patch: **** Only garbage was found in the patch input. Now I've see the same issue on different builder (with Ubuntu 12.04). (From OE-Core master rev: ec3bb2c2203b2e8bafc1a631f623f858779e20b7) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/ltp/ltp/0001-Rename-runtests_noltp.sh-script-so-have-unique-name.patch202
-rw-r--r--meta/recipes-extended/ltp/ltp_20130503.bb4
2 files changed, 205 insertions, 1 deletions
diff --git a/meta/recipes-extended/ltp/ltp/0001-Rename-runtests_noltp.sh-script-so-have-unique-name.patch b/meta/recipes-extended/ltp/ltp/0001-Rename-runtests_noltp.sh-script-so-have-unique-name.patch
new file mode 100644
index 0000000000..1b4d2324a5
--- /dev/null
+++ b/meta/recipes-extended/ltp/ltp/0001-Rename-runtests_noltp.sh-script-so-have-unique-name.patch
@@ -0,0 +1,202 @@
+From 9751a6526cffcdf4e3dc2cb33641259a7be00e19 Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Sat, 7 Dec 2013 18:24:32 +0100
+Subject: [PATCH] Rename runtests_noltp.sh script so have unique name
+
+* they are installed in the same target path
+ /opt/ltp/testcases/bin/runtests_noltp.sh
+ and overwrite each other in non-deterministic way
+ when multiple processes are used in "make install"
+
+ ./temp/log.do_install:install -m 00775
+ "ltp/20120903-r2/ltp-20120903/testcases/kernel/containers/sysvipc/runtests_noltp.sh"
+ "ltp/20120903-r2/image/opt/ltp/testcases/bin/runtests_noltp.sh"
+ ./temp/log.do_install:install -m 00775
+ "ltp/20120903-r2/ltp-20120903/testcases/kernel/containers/utsname/runtests_noltp.sh"
+ "ltp/20120903-r2/image/opt/ltp/testcases/bin/runtests_noltp.sh"
+
+Upstream-Status: Pending
+
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+---
+ .../kernel/containers/sysvipc/runipctests_noltp.sh | 31 ++++++++++++++++
+ .../kernel/containers/sysvipc/runtests_noltp.sh | 31 ----------------
+ .../kernel/containers/utsname/runtests_noltp.sh | 41 ----------------------
+ .../kernel/containers/utsname/runutstests_noltp.sh | 41 ++++++++++++++++++++++
+ 4 files changed, 72 insertions(+), 72 deletions(-)
+ create mode 100644 testcases/kernel/containers/sysvipc/runipctests_noltp.sh
+ delete mode 100644 testcases/kernel/containers/sysvipc/runtests_noltp.sh
+ delete mode 100755 testcases/kernel/containers/utsname/runtests_noltp.sh
+ create mode 100755 testcases/kernel/containers/utsname/runutstests_noltp.sh
+
+diff --git a/testcases/kernel/containers/sysvipc/runipctests_noltp.sh b/testcases/kernel/containers/sysvipc/runipctests_noltp.sh
+new file mode 100644
+index 0000000..84f398f
+--- /dev/null
++++ b/testcases/kernel/containers/sysvipc/runipctests_noltp.sh
+@@ -0,0 +1,31 @@
++#!/bin/sh
++################################################################################
++## ##
++## Copyright (c) International Business Machines Corp., 2007 ##
++## ##
++## This program is free software; you can redistribute it and#or modify ##
++## it under the terms of the GNU General Public License as published by ##
++## the Free Software Foundation; either version 2 of the License, or ##
++## (at your option) any later version. ##
++## ##
++## This program is distributed in the hope that it will be useful, but ##
++## WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY ##
++## or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License ##
++## for more details. ##
++## ##
++## You should have received a copy of the GNU General Public License ##
++## along with this program; if not, write to the Free Software ##
++## Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA ##
++## ##
++################################################################################
++
++exit_code=0
++echo "sysvipc tests"
++for type in none clone unshare; do
++ echo "**sysvipc $type"
++ ./shmnstest_noltp $type
++ if [ $? -ne 0 ]; then
++ exit_code=$?
++ fi
++done
++exit $exit_code
+diff --git a/testcases/kernel/containers/sysvipc/runtests_noltp.sh b/testcases/kernel/containers/sysvipc/runtests_noltp.sh
+deleted file mode 100644
+index 84f398f..0000000
+--- a/testcases/kernel/containers/sysvipc/runtests_noltp.sh
++++ /dev/null
+@@ -1,31 +0,0 @@
+-#!/bin/sh
+-################################################################################
+-## ##
+-## Copyright (c) International Business Machines Corp., 2007 ##
+-## ##
+-## This program is free software; you can redistribute it and#or modify ##
+-## it under the terms of the GNU General Public License as published by ##
+-## the Free Software Foundation; either version 2 of the License, or ##
+-## (at your option) any later version. ##
+-## ##
+-## This program is distributed in the hope that it will be useful, but ##
+-## WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY ##
+-## or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License ##
+-## for more details. ##
+-## ##
+-## You should have received a copy of the GNU General Public License ##
+-## along with this program; if not, write to the Free Software ##
+-## Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA ##
+-## ##
+-################################################################################
+-
+-exit_code=0
+-echo "sysvipc tests"
+-for type in none clone unshare; do
+- echo "**sysvipc $type"
+- ./shmnstest_noltp $type
+- if [ $? -ne 0 ]; then
+- exit_code=$?
+- fi
+-done
+-exit $exit_code
+diff --git a/testcases/kernel/containers/utsname/runtests_noltp.sh b/testcases/kernel/containers/utsname/runtests_noltp.sh
+deleted file mode 100755
+index 43cb7e2..0000000
+--- a/testcases/kernel/containers/utsname/runtests_noltp.sh
++++ /dev/null
+@@ -1,41 +0,0 @@
+-#!/bin/sh
+-################################################################################
+-## ##
+-## Copyright (c) International Business Machines Corp., 2007 ##
+-## ##
+-## This program is free software; you can redistribute it and#or modify ##
+-## it under the terms of the GNU General Public License as published by ##
+-## the Free Software Foundation; either version 2 of the License, or ##
+-## (at your option) any later version. ##
+-## ##
+-## This program is distributed in the hope that it will be useful, but ##
+-## WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY ##
+-## or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License ##
+-## for more details. ##
+-## ##
+-## You should have received a copy of the GNU General Public License ##
+-## along with this program; if not, write to the Free Software ##
+-## Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA ##
+-## ##
+-################################################################################
+-
+-oldhostname=`hostname`
+-exit_code=0
+-echo "unshare tests"
+-for i in `seq 1 5`; do
+- echo "test $i (unshare)"
+- ./utstest_noltp unshare $i
+- if [ $? -ne 0 ]; then
+- exit_code=$?
+- fi
+-done
+-echo "clone tests"
+-for i in `seq 1 5`; do
+- echo "test $i (clone)"
+- ./utstest_noltp clone $i
+- if [ $? -ne 0 ]; then
+- exit_code=$?
+- fi
+-done
+-hostname "$oldhostname"
+-exit $exit_code
+diff --git a/testcases/kernel/containers/utsname/runutstests_noltp.sh b/testcases/kernel/containers/utsname/runutstests_noltp.sh
+new file mode 100755
+index 0000000..43cb7e2
+--- /dev/null
++++ b/testcases/kernel/containers/utsname/runutstests_noltp.sh
+@@ -0,0 +1,41 @@
++#!/bin/sh
++################################################################################
++## ##
++## Copyright (c) International Business Machines Corp., 2007 ##
++## ##
++## This program is free software; you can redistribute it and#or modify ##
++## it under the terms of the GNU General Public License as published by ##
++## the Free Software Foundation; either version 2 of the License, or ##
++## (at your option) any later version. ##
++## ##
++## This program is distributed in the hope that it will be useful, but ##
++## WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY ##
++## or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License ##
++## for more details. ##
++## ##
++## You should have received a copy of the GNU General Public License ##
++## along with this program; if not, write to the Free Software ##
++## Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA ##
++## ##
++################################################################################
++
++oldhostname=`hostname`
++exit_code=0
++echo "unshare tests"
++for i in `seq 1 5`; do
++ echo "test $i (unshare)"
++ ./utstest_noltp unshare $i
++ if [ $? -ne 0 ]; then
++ exit_code=$?
++ fi
++done
++echo "clone tests"
++for i in `seq 1 5`; do
++ echo "test $i (clone)"
++ ./utstest_noltp clone $i
++ if [ $? -ne 0 ]; then
++ exit_code=$?
++ fi
++done
++hostname "$oldhostname"
++exit $exit_code
+--
+1.8.4.3
+
diff --git a/meta/recipes-extended/ltp/ltp_20130503.bb b/meta/recipes-extended/ltp/ltp_20130503.bb
index 387826dcfd..9e1183c1fd 100644
--- a/meta/recipes-extended/ltp/ltp_20130503.bb
+++ b/meta/recipes-extended/ltp/ltp_20130503.bb
@@ -21,7 +21,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
DEPENDS = "attr libaio libcap acl openssl"
-SRC_URI = "${SOURCEFORGE_MIRROR}/ltp/ltp-full-${PV}.bz2"
+SRC_URI = "${SOURCEFORGE_MIRROR}/ltp/ltp-full-${PV}.bz2 \
+ file://0001-Rename-runtests_noltp.sh-script-so-have-unique-name.patch \
+"
SRC_URI[md5sum] = "d448d9e9731d7ef45352fc74633cc97f"
SRC_URI[sha256sum] = "afdb1479e73d4da7f0d4d5d3fe1570bc5fc96e3317d4a5c10c59c046d3dfa4a0"