aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2014-03-04 14:51:02 -0800
committerAndreas Oberritter <obi@opendreambox.org>2015-02-23 17:15:27 +0100
commiteaa4f4f958db82dd32afc9818273093e669e0c26 (patch)
treeb6e72e38bb196dd55e8c40a1005331bebd8b7c33 /meta/recipes-extended
parente761700f909a128fa4858ef5686ba1b71a7089f8 (diff)
downloadopenembedded-core-contrib-eaa4f4f958db82dd32afc9818273093e669e0c26.tar.gz
parted: add patch to handle deprecated readline function
Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit ebaa5485abda86691b0eeadaf689d75072357178) Signed-off-by: Andreas Oberritter <obi@opendreambox.org> (merge fixes)
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/parted/parted-3.1/fix-deprecated-readline.patch34
-rw-r--r--meta/recipes-extended/parted/parted_3.1.bb4
2 files changed, 37 insertions, 1 deletions
diff --git a/meta/recipes-extended/parted/parted-3.1/fix-deprecated-readline.patch b/meta/recipes-extended/parted/parted-3.1/fix-deprecated-readline.patch
new file mode 100644
index 0000000000..c4ca06d407
--- /dev/null
+++ b/meta/recipes-extended/parted/parted-3.1/fix-deprecated-readline.patch
@@ -0,0 +1,34 @@
+
+From: Gustavo Zacarias
+Subject: bug#16929: [PATCH] ui: switch to new-style readline typedef
+Date: Mon, 3 Mar 2014 10:40:08 -0300
+
+The CPPFunction typedef (among others) have been deprecated in favour of
+specific prototyped typedefs since readline 4.2 (circa 2001).
+It's been working since because compatibility typedefs have been in
+place until they where removed in the recent readline 6.3 release.
+Switch to the new style to avoid build breakage.
+
+Signed-off-by: Gustavo Zacarias <address@hidden>
+
+Upstream-Status: Backport
+
+Signed-off-by: Saul Wold <sgw@linux.intel.com>
+
+---
+ parted/ui.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/parted/ui.c b/parted/ui.c
+index 786deed..b33f6fc 100644
+--- a/parted/ui.c
++++ b/parted/ui.c
+@@ -1470,7 +1470,7 @@ init_readline (void)
+ #ifdef HAVE_LIBREADLINE
+ if (!opt_script_mode) {
+ rl_initialize ();
+- rl_attempted_completion_function = (CPPFunction*) complete_function;
++ rl_attempted_completion_function = (rl_completion_func_t *) complete_function;
+ readline_state.in_readline = 0;
+ }
+ #endif
diff --git a/meta/recipes-extended/parted/parted_3.1.bb b/meta/recipes-extended/parted/parted_3.1.bb
index 079b29593d..0c4d80cb2d 100644
--- a/meta/recipes-extended/parted/parted_3.1.bb
+++ b/meta/recipes-extended/parted/parted_3.1.bb
@@ -11,7 +11,9 @@ SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.xz \
file://syscalls.patch \
file://fix-git-version-gen.patch \
file://fix-doc-mandir.patch \
- file://fix-dvh-overflows.patch"
+ file://fix-dvh-overflows.patch \
+ file://fix-deprecated-readline.patch \
+"
SRC_URI[md5sum] = "5d89d64d94bcfefa9ce8f59f4b81bdcb"
SRC_URI[sha256sum] = "5e9cc1f91eaf016e5033d85b9b893fd6d3ffaca532a48de1082df9b94225ca15"