aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorAlex Kiernan <alex.kiernan@gmail.com>2018-08-02 14:42:29 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-07 12:12:55 +0100
commit61522645a1ccc8342706960efe90896001e94a8b (patch)
tree75be319f7afa6c24dd69afb941301dc6be2ffbea /meta/recipes-extended
parent65e0b318b8521c3213249693cc898374effcf531 (diff)
downloadopenembedded-core-contrib-61522645a1ccc8342706960efe90896001e94a8b.tar.gz
net-tools: Ensure quilt only operates on local patches
When net-tools is built and the local patches haven't been applied, then `quilt pop -a` will climb parent directories attempting to find a {patches/.pc} directory; if this succeeds then we end up popping off some completely unrelated patches from a parent directory. Ensure that we do have a local patches directory and then turn off the directory climbing so that we avoid this problem. Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/net-tools/net-tools_1.60-26.bb11
1 files changed, 10 insertions, 1 deletions
diff --git a/meta/recipes-extended/net-tools/net-tools_1.60-26.bb b/meta/recipes-extended/net-tools/net-tools_1.60-26.bb
index 5657fd8c5b..a4e3285cdb 100644
--- a/meta/recipes-extended/net-tools/net-tools_1.60-26.bb
+++ b/meta/recipes-extended/net-tools/net-tools_1.60-26.bb
@@ -48,7 +48,16 @@ PARALLEL_MAKE = ""
# up all previously applied patches in the start
nettools_do_patch() {
cd ${S}
- quilt pop -a || true
+ # it's important that we only pop the existing patches when they've
+ # been applied, otherwise quilt will climb the directory tree
+ # and reverse out some completely different set of patches
+ if [ -d ${S}/patches ]; then
+ # whilst this is the default directory, doing it like this
+ # defeats the directory climbing that quilt will otherwise
+ # do; note the directory must exist to defeat this, hence
+ # the test inside which we operate
+ QUILT_PATCHES=${S}/patches quilt pop -a
+ fi
if [ -d ${S}/.pc-nettools ]; then
rm -rf ${S}/.pc
mv ${S}/.pc-nettools ${S}/.pc