summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorYan Xinkuan <yanxk.fnst@fujitsu.com>2022-11-01 07:55:11 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-11-02 09:20:53 +0000
commit98b058a039ae8a49437c306f684f919c93df55fd (patch)
tree687e457c39b01c7e47e41a9ec106afc14114f55f /meta/recipes-extended
parenta918ea5645d8a67cedaf3ecf6c382520bbcad85b (diff)
downloadopenembedded-core-contrib-98b058a039ae8a49437c306f684f919c93df55fd.tar.gz
bc: Add ptest.
Add ptest for OSS 'bc' by using 'bc' in the system to do calculation jobs according to the .b files from the source file. Test example as below: ...... .00673400673400673400 “PASS: bc/div.b” 99836408603283573660347145562829683495827909199408566065153345558783\ 9427595471.89114392327665123852 “PASS: bc/exp.b” length(b)= 1406 “PASS: bc/fact.b” ...... If bc runs the .b files and does not crash, it would 'PASS', otherwise 'FAIL'. Tested in qemux86-64, with kvm enabled, test cost 12 secs, so it should be a fast test. Thanks to Ross Burton and Alexander Kanavin for the professional guidance. Signed-off-by: Yan Xinkuan <yanxk.fnst@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/bc/bc/run-ptest9
-rw-r--r--meta/recipes-extended/bc/bc_1.07.1.bb9
2 files changed, 16 insertions, 2 deletions
diff --git a/meta/recipes-extended/bc/bc/run-ptest b/meta/recipes-extended/bc/bc/run-ptest
new file mode 100644
index 0000000000..66a1b9d708
--- /dev/null
+++ b/meta/recipes-extended/bc/bc/run-ptest
@@ -0,0 +1,9 @@
+#! /bin/sh
+
+for TEST in *.b; do
+ if bc -l $TEST </dev/null; then
+ echo “PASS: bc/$TEST”
+ else
+ echo “FAIL: bc/$TEST”
+ fi
+done
diff --git a/meta/recipes-extended/bc/bc_1.07.1.bb b/meta/recipes-extended/bc/bc_1.07.1.bb
index 1bec76bb2a..178588f11b 100644
--- a/meta/recipes-extended/bc/bc_1.07.1.bb
+++ b/meta/recipes-extended/bc/bc_1.07.1.bb
@@ -15,11 +15,12 @@ DEPENDS = "flex-native"
SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz \
file://no-gen-libmath.patch \
file://libmath.h \
- file://0001-dc-fix-exit-code-of-q-command.patch"
+ file://0001-dc-fix-exit-code-of-q-command.patch \
+ file://run-ptest"
SRC_URI[md5sum] = "cda93857418655ea43590736fc3ca9fc"
SRC_URI[sha256sum] = "62adfca89b0a1c0164c2cdca59ca210c1d44c3ffc46daf9931cf4942664cb02a"
-inherit autotools texinfo update-alternatives
+inherit autotools texinfo update-alternatives ptest
PACKAGECONFIG ??= "readline"
PACKAGECONFIG[readline] = "--with-readline,--without-readline,readline"
@@ -29,6 +30,10 @@ do_compile:prepend() {
cp -f ${WORKDIR}/libmath.h ${B}/bc/libmath.h
}
+do_install_ptest() {
+ install ${S}/Test/*.b ${D}${PTEST_PATH}
+}
+
ALTERNATIVE:${PN} = "bc dc"
ALTERNATIVE_PRIORITY = "100"