summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorMalte Schmidt <malte.schmidt@weidmueller.com>2023-11-16 12:54:56 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-11-20 15:30:46 +0000
commit4db3438d500936d94b55294f21db156fb049888c (patch)
tree7c2de3af89461e0302eef378ef474a9ee8a64fd1 /meta/recipes-extended
parent0a1d791e47b71b14c3dd7f41fc175c2aafacd392 (diff)
downloadopenembedded-core-contrib-4db3438d500936d94b55294f21db156fb049888c.tar.gz
sysstat: use nonarch libdir for tmpfiles.d
The documentation of systemd states that /etc/tmpfiles.d should be reserved for the local administrator and packages should put their files in /usr/lib/tmpfiles.d [1]. [1] https://www.freedesktop.org/software/systemd/man/tmpfiles.d.html Signed-off-by: Malte Schmidt <malte.schmidt@weidmueller.com> Signed-off-by: Stefan Herbrechtsmeier <stefan.herbrechtsmeier@weidmueller.com> Signed-off-by: Lukas Funke <lukas.funke@weidmueller.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/sysstat/sysstat_12.7.4.bb10
1 files changed, 7 insertions, 3 deletions
diff --git a/meta/recipes-extended/sysstat/sysstat_12.7.4.bb b/meta/recipes-extended/sysstat/sysstat_12.7.4.bb
index 134fd5cf96..660bc634a0 100644
--- a/meta/recipes-extended/sysstat/sysstat_12.7.4.bb
+++ b/meta/recipes-extended/sysstat/sysstat_12.7.4.bb
@@ -48,9 +48,9 @@ do_install() {
install -m 0644 ${WORKDIR}/99_sysstat ${D}/etc/default/volatiles
fi
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -d ${D}${sysconfdir}/tmpfiles.d
+ install -d ${D}${nonarch_libdir}/tmpfiles.d
echo "d ${localstatedir}/log/sa - - - -" \
- > ${D}${sysconfdir}/tmpfiles.d/sysstat.conf
+ > ${D}${nonarch_libdir}/tmpfiles.d/sysstat.conf
# Unless both cron and systemd are enabled, install our own
# systemd unit file. Otherwise the package will install one.
@@ -70,7 +70,11 @@ pkg_postinst:${PN} () {
fi
}
-FILES:${PN} += "${systemd_system_unitdir} ${nonarch_base_libdir}/systemd"
+FILES:${PN} += " \
+ ${systemd_system_unitdir} \
+ ${nonarch_base_libdir}/systemd \
+ ${nonarch_libdir}/tmpfiles.d \
+"
TARGET_CC_ARCH += "${LDFLAGS}"