summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorFrank WOLFF <frank.wolff@smile.fr>2023-04-05 16:36:04 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-04-13 11:55:40 +0100
commit0bdfe34c016c8db1f18d76b59a38af280b4c70aa (patch)
treef9d037b34de96c92db3f46021de04bd778b49279 /meta/recipes-extended
parentc589c87a8caef0afbc731c219fe713ba970a2055 (diff)
downloadopenembedded-core-contrib-0bdfe34c016c8db1f18d76b59a38af280b4c70aa.tar.gz
logrotate: add ptest support
Below is an extract of the test log: root@qemux86-64:~# ptest-runner START: ptest-runner 2023-04-05T12:20 BEGIN: /usr/lib/logrotate/ptest make check-TESTS make[1]: Entering directory '/usr/lib/logrotate/ptest' make[2]: Entering directory '/usr/lib/logrotate/ptest' PASS: test-0001.sh PASS: test-0002.sh ... ... PASS: test-0107.sh PASS: test-0108.sh ============================================================================ Testsuite summary for logrotate 3.21.0 ============================================================================ # TOTAL: 102 # PASS: 97 # SKIP: 5 # XFAIL: 0 # FAIL: 0 # XPASS: 0 # ERROR: 0 ============================================================================ make[2]: Leaving directory '/usr/lib/logrotate/ptest' make[1]: Leaving directory '/usr/lib/logrotate/ptest' DURATION: 353 END: /usr/lib/logrotate/ptest 2023-04-05T12:26 STOP: ptest-runner TOTAL: 1 FAIL: 0 Reviewed-by: Yoann CONGAL <yoann.congal@smile.fr> Signed-off-by: Frank WOLFF <frank.wolff@smile.fr> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Diffstat (limited to 'meta/recipes-extended')
-rwxr-xr-xmeta/recipes-extended/logrotate/logrotate/run-ptest5
-rw-r--r--meta/recipes-extended/logrotate/logrotate_3.21.0.bb30
2 files changed, 33 insertions, 2 deletions
diff --git a/meta/recipes-extended/logrotate/logrotate/run-ptest b/meta/recipes-extended/logrotate/logrotate/run-ptest
new file mode 100755
index 0000000000..b272def65f
--- /dev/null
+++ b/meta/recipes-extended/logrotate/logrotate/run-ptest
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+set -u
+
+make -k check
diff --git a/meta/recipes-extended/logrotate/logrotate_3.21.0.bb b/meta/recipes-extended/logrotate/logrotate_3.21.0.bb
index 4e4ea10628..87c0d9ae60 100644
--- a/meta/recipes-extended/logrotate/logrotate_3.21.0.bb
+++ b/meta/recipes-extended/logrotate/logrotate_3.21.0.bb
@@ -10,7 +10,9 @@ DEPENDS="coreutils popt"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-SRC_URI = "${GITHUB_BASE_URI}/download/${PV}/${BP}.tar.xz"
+SRC_URI = "${GITHUB_BASE_URI}/download/${PV}/${BP}.tar.xz \
+ file://run-ptest \
+ "
SRC_URI[sha256sum] = "8fa12015e3b8415c121fc9c0ca53aa872f7b0702f543afda7e32b6c4900f6516"
@@ -44,7 +46,7 @@ EXTRA_OEMAKE = "\
# INSTALL=install and BASEDIR=/usr.
OS_NAME = "Linux"
-inherit autotools systemd github-releases
+inherit autotools systemd github-releases ptest
SYSTEMD_SERVICE:${PN} = "\
${BPN}.service \
@@ -86,3 +88,27 @@ do_install(){
install -p -m 0755 ${S}/examples/logrotate.cron ${D}${sysconfdir}/cron.daily/logrotate
fi
}
+
+do_install_ptest() {
+ cp -r ${S}/test/* ${D}${PTEST_PATH}
+ cp ${S}/test-driver ${D}${PTEST_PATH}
+ cp ${B}/test/Makefile ${D}${PTEST_PATH}
+
+ # Do not rebuild Makefile
+ sed -i 's/^Makefile:/_Makefile:/' ${D}${PTEST_PATH}/Makefile
+
+ # Fix top_builddir and top_srcdir
+ sed -e 's/^top_builddir = \(.*\)/top_builddir = ./' \
+ -e 's/^top_srcdir = \(.*\)/top_srcdir = ./' \
+ -i ${D}${PTEST_PATH}/Makefile
+
+ # Replace bash with sh
+ sed -i 's,/bin/bash,/bin/sh,' ${D}${PTEST_PATH}/Makefile
+
+ # Replace gawk with awk
+ sed -i 's/gawk/awk/' ${D}${PTEST_PATH}/Makefile
+ ln -s ${sbindir}/logrotate ${D}${PTEST_PATH}
+}
+
+# coreutils is needed to have "readlink"
+RDEPENDS:${PN}-ptest += "make coreutils"