aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorFahad Usman <fahad_usman@mentor.com>2014-08-26 13:16:49 +0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-27 12:12:06 +0100
commit885cec11c978975d5c51ded92882a3b00d5ccf8c (patch)
tree0e50916ad46a0256b3d9b0c6dbe40a9af817e95b /meta/recipes-extended
parenta46d3646a3e1781be4423b508ea63996b3cfca8a (diff)
downloadopenembedded-core-contrib-885cec11c978975d5c51ded92882a3b00d5ccf8c.tar.gz
logrotate: add packageconfigs
add packageconfigs for acl and selinux. Signed-off-by: Fahad Usman <fahad.usman@gmail.com> Signed-off-by: Christopher Larson <kergoth@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/logrotate/logrotate_3.8.7.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta/recipes-extended/logrotate/logrotate_3.8.7.bb b/meta/recipes-extended/logrotate/logrotate_3.8.7.bb
index 42cd764da0..faa8e0264f 100644
--- a/meta/recipes-extended/logrotate/logrotate_3.8.7.bb
+++ b/meta/recipes-extended/logrotate/logrotate_3.8.7.bb
@@ -16,6 +16,11 @@ SRC_URI = "https://fedorahosted.org/releases/l/o/logrotate/logrotate-${PV}.tar.g
SRC_URI[md5sum] = "99e08503ef24c3e2e3ff74cc5f3be213"
SRC_URI[sha256sum] = "f6ba691f40e30e640efa2752c1f9499a3f9738257660994de70a45fe00d12b64"
+PACKAGECONFIG ?= "\
+ ${@base_contains('DISTRO_FEATURES', 'acl', 'acl', '', d)} \
+ ${@base_contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)} \
+"
+
# If RPM_OPT_FLAGS is unset, it adds -g itself rather than obeying our
# optimization variables, so use it rather than EXTRA_CFLAGS.
EXTRA_OEMAKE = "\
@@ -25,6 +30,9 @@ EXTRA_OEMAKE = "\
'CC=${CC}' \
'RPM_OPT_FLAGS=${CFLAGS}' \
'EXTRA_LDFLAGS=${LDFLAGS}' \
+ \
+ ${@base_contains('PACKAGECONFIG', 'acl', 'WITH_ACL=yes', '', d)} \
+ ${@base_contains('PACKAGECONFIG', 'selinux', 'WITH_SELINUX=yes', '', d)} \
"
# OS_NAME in the makefile defaults to `uname -s`. The behavior for