aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorDmitry Rozhkov <dmitry.rozhkov@intel.com>2016-01-13 10:43:12 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-17 11:32:21 +0000
commitebf68926139ae5374c4d2669930d7f3817ad8f5a (patch)
tree7c7166c4d0201ff69701f44b47bf07f426514412 /meta/recipes-extended
parentcd2eb45ce1f9be15e133d6fe940c1cff2199099b (diff)
downloadopenembedded-core-contrib-ebf68926139ae5374c4d2669930d7f3817ad8f5a.tar.gz
libarchive: Add bsdtar and bsdcpio packages
Some products might need to use a tar replacement that 1. supports xattrs and 2. has more permissive license than GNU tar. And the bsdtar binary produced from libarchive meets these requirements. Signed-off-by: Dmitry Rozhkov <dmitry.rozhkov@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/libarchive/libarchive_3.1.2.bb18
1 files changed, 17 insertions, 1 deletions
diff --git a/meta/recipes-extended/libarchive/libarchive_3.1.2.bb b/meta/recipes-extended/libarchive/libarchive_3.1.2.bb
index 716db9aff0..202507d64c 100644
--- a/meta/recipes-extended/libarchive/libarchive_3.1.2.bb
+++ b/meta/recipes-extended/libarchive/libarchive_3.1.2.bb
@@ -39,7 +39,7 @@ SRC_URI = "http://libarchive.org/downloads/libarchive-${PV}.tar.gz \
SRC_URI[md5sum] = "efad5a503f66329bb9d2f4308b5de98a"
SRC_URI[sha256sum] = "eb87eacd8fe49e8d90c8fdc189813023ccc319c5e752b01fb6ad0cc7b2c53d5e"
-inherit autotools lib_package pkgconfig
+inherit autotools update-alternatives pkgconfig
CPPFLAGS += "-I${WORKDIR}/extra-includes"
@@ -50,4 +50,20 @@ do_configure_prepend() {
cp -R ${STAGING_INCDIR_NATIVE}/ext2fs ${WORKDIR}/extra-includes/
}
+ALTERNATIVE_PRIORITY = "100"
+
+PACKAGES =+ "bsdtar"
+FILES_bsdtar = "${bindir}/bsdtar"
+
+ALTERNATIVE_bsdtar = "tar"
+ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar"
+ALTERNATIVE_TARGET[tar] = "${bindir}/bsdtar"
+
+PACKAGES =+ "bsdcpio"
+FILES_bsdcpio = "${bindir}/bsdcpio"
+
+ALTERNATIVE_bsdcpio = "cpio"
+ALTERNATIVE_LINK_NAME[cpio] = "${base_bindir}/cpio"
+ALTERNATIVE_TARGET[cpio] = "${bindir}/bsdcpio"
+
BBCLASSEXTEND = "native nativesdk"