aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2014-03-06 16:46:08 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-07 14:44:25 +0000
commit959396d5319df6d6599cc74077e85182768b92af (patch)
tree46a6d136aa0791c21238ad61388dc03a7d143ff0 /meta/recipes-extended
parentb60c68a4ea937a647e13d69dfecefb7dcbda95a0 (diff)
downloadopenembedded-core-contrib-959396d5319df6d6599cc74077e85182768b92af.tar.gz
core-image-basic / packagegroup-core-basic: rename to *-full-cmdline
This more accurately represents what this image and packagegroup are intended to provide (a more complete command-line environment similar to what you would find on a traditional Linux system), and avoids confusion with the similarly named core-image-base and packagegroup-base. Fixes [YOCTO #2424]. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/images/core-image-full-cmdline.bb (renamed from meta/recipes-extended/images/core-image-basic.bb)2
-rw-r--r--meta/recipes-extended/images/core-image-lsb.bb2
-rw-r--r--meta/recipes-extended/packagegroups/packagegroup-core-basic.bb138
-rw-r--r--meta/recipes-extended/packagegroups/packagegroup-core-full-cmdline.bb163
4 files changed, 165 insertions, 140 deletions
diff --git a/meta/recipes-extended/images/core-image-basic.bb b/meta/recipes-extended/images/core-image-full-cmdline.bb
index d599e720f1..4d69073d9d 100644
--- a/meta/recipes-extended/images/core-image-basic.bb
+++ b/meta/recipes-extended/images/core-image-full-cmdline.bb
@@ -5,7 +5,7 @@ IMAGE_FEATURES += "splash ssh-server-openssh"
IMAGE_INSTALL = "\
packagegroup-core-boot \
- packagegroup-core-basic \
+ packagegroup-core-full-cmdline \
${CORE_IMAGE_EXTRA_INSTALL} \
"
diff --git a/meta/recipes-extended/images/core-image-lsb.bb b/meta/recipes-extended/images/core-image-lsb.bb
index 1ef7f11742..ed316a64e7 100644
--- a/meta/recipes-extended/images/core-image-lsb.bb
+++ b/meta/recipes-extended/images/core-image-lsb.bb
@@ -5,7 +5,7 @@ IMAGE_FEATURES += "splash ssh-server-openssh hwcodecs package-management"
IMAGE_INSTALL = "\
${CORE_IMAGE_BASE_INSTALL} \
- packagegroup-core-basic \
+ packagegroup-core-full-cmdline \
packagegroup-core-lsb \
"
diff --git a/meta/recipes-extended/packagegroups/packagegroup-core-basic.bb b/meta/recipes-extended/packagegroups/packagegroup-core-basic.bb
deleted file mode 100644
index f3b4ff7f0b..0000000000
--- a/meta/recipes-extended/packagegroups/packagegroup-core-basic.bb
+++ /dev/null
@@ -1,138 +0,0 @@
-#
-# Copyright (C) 2010 Intel Corporation
-#
-
-SUMMARY = "Create Basic Image Tasks"
-PR = "r6"
-LICENSE = "MIT"
-
-inherit packagegroup
-
-PACKAGES = "\
- packagegroup-core-basic \
- packagegroup-core-basic-libs \
- packagegroup-core-basic-utils \
- packagegroup-core-basic-extended \
- packagegroup-core-dev-utils \
- packagegroup-core-multiuser \
- packagegroup-core-initscripts \
- packagegroup-core-sys-services \
- "
-
-python __anonymous () {
- # For backwards compatibility after rename
- packages = d.getVar("PACKAGES", True).split()
- for pkg in packages:
- d.appendVar("RPROVIDES_%s" % pkg, pkg.replace("packagegroup-core", "task-core"))
- d.appendVar("RREPLACES_%s" % pkg, pkg.replace("packagegroup-core", "task-core"))
- d.appendVar("RCONFLICTS_%s" % pkg, pkg.replace("packagegroup-core", "task-core"))
-}
-
-
-RDEPENDS_packagegroup-core-basic = "\
- packagegroup-core-basic-libs \
- packagegroup-core-basic-utils \
- packagegroup-core-basic-extended \
- packagegroup-core-dev-utils \
- packagegroup-core-multiuser \
- packagegroup-core-initscripts \
- packagegroup-core-sys-services \
- "
-
-RDEPENDS_packagegroup-core-basic-libs = "\
- glib-2.0 \
- "
-
-RDEPENDS_packagegroup-core-basic-utils = "\
- bash \
- acl \
- attr \
- bc \
- coreutils \
- cpio \
- e2fsprogs \
- ed \
- file \
- findutils \
- gawk \
- gmp \
- grep \
- makedevs \
- mc \
- mc-fish \
- mc-helpers \
- mc-helpers-perl \
- mc-helpers-python \
- mktemp \
- ncurses \
- net-tools \
- pax \
- popt \
- procps \
- psmisc \
- sed \
- tar \
- time \
- util-linux \
- zlib \
- "
-
-RDEPENDS_packagegroup-core-basic-extended = "\
- iproute2 \
- iputils \
- iptables \
- module-init-tools \
- openssl \
- "
-
-RDEPENDS_packagegroup-core-dev-utils = "\
- byacc \
- diffutils \
- m4 \
- make \
- patch \
- "
-
-VIRTUAL-RUNTIME_initscripts ?= "initscripts"
-VIRTUAL-RUNTIME_init_manager ?= "sysvinit"
-VIRTUAL-RUNTIME_login_manager ?= "busybox"
-VIRTUAL-RUNTIME_syslog ?= "sysklogd"
-RDEPENDS_packagegroup-core-initscripts = "\
- ${VIRTUAL-RUNTIME_initscripts} \
- ${VIRTUAL-RUNTIME_init_manager} \
- ethtool \
- ${VIRTUAL-RUNTIME_login_manager} \
- ${VIRTUAL-RUNTIME_syslog} \
- "
-
-RDEPENDS_packagegroup-core-multiuser = "\
- cracklib \
- gzip \
- ${@base_contains('DISTRO_FEATURES', 'pam', 'libuser', '', d)} \
- shadow \
- sudo \
- "
-
-RDEPENDS_packagegroup-core-sys-services = "\
- at \
- bzip2 \
- cronie \
- dbus \
- dbus-glib \
- python-dbus \
- elfutils \
- gzip \
- less \
- libcap \
- libevent \
- lighttpd \
- logrotate \
- nfs-utils \
- pciutils \
- libpcre \
- rpcbind \
- sysfsutils \
- tcp-wrappers \
- tzdata \
- "
-
diff --git a/meta/recipes-extended/packagegroups/packagegroup-core-full-cmdline.bb b/meta/recipes-extended/packagegroups/packagegroup-core-full-cmdline.bb
new file mode 100644
index 0000000000..b87213cb99
--- /dev/null
+++ b/meta/recipes-extended/packagegroups/packagegroup-core-full-cmdline.bb
@@ -0,0 +1,163 @@
+#
+# Copyright (C) 2010 Intel Corporation
+#
+
+SUMMARY = "Standard full-featured Linux system"
+DESCRIPTION = "Package group bringing in packages needed for a more traditional full-featured Linux system"
+PR = "r6"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-core-full-cmdline \
+ packagegroup-core-full-cmdline-libs \
+ packagegroup-core-full-cmdline-utils \
+ packagegroup-core-full-cmdline-extended \
+ packagegroup-core-full-cmdline-dev-utils \
+ packagegroup-core-full-cmdline-multiuser \
+ packagegroup-core-full-cmdline-initscripts \
+ packagegroup-core-full-cmdline-sys-services \
+ "
+
+python __anonymous () {
+ # For backwards compatibility after rename
+ namemap = {}
+ namemap["packagegroup-core-full-cmdline"] = "packagegroup-core-basic"
+ namemap["packagegroup-core-full-cmdline-libs"] = "packagegroup-core-basic-libs"
+ namemap["packagegroup-core-full-cmdline-utils"] = "packagegroup-core-basic-utils"
+ namemap["packagegroup-core-full-cmdline-extended"] = "packagegroup-core-basic-extended"
+ namemap["packagegroup-core-full-cmdline-dev-utils"] = "packagegroup-core-dev-utils"
+ namemap["packagegroup-core-full-cmdline-multiuser"] = "packagegroup-core-multiuser"
+ namemap["packagegroup-core-full-cmdline-initscripts"] = "packagegroup-core-initscripts"
+ namemap["packagegroup-core-full-cmdline-sys-services"] = "packagegroup-core-sys-services"
+
+ packages = d.getVar("PACKAGES", True).split()
+ for pkg in packages:
+ if pkg.endswith('-dev'):
+ mapped = namemap.get(pkg[:-4], None)
+ if mapped:
+ mapped += '-dev'
+ elif pkg.endswith('-dbg'):
+ mapped = namemap.get(pkg[:-4], None)
+ if mapped:
+ mapped += '-dbg'
+ else:
+ mapped = namemap.get(pkg, None)
+
+ if mapped:
+ oldtaskname = mapped.replace("packagegroup-core", "task-core")
+ mapstr = " %s %s" % (mapped, oldtaskname)
+ d.appendVar("RPROVIDES_%s" % pkg, mapstr)
+ d.appendVar("RREPLACES_%s" % pkg, mapstr)
+ d.appendVar("RCONFLICTS_%s" % pkg, mapstr)
+}
+
+
+RDEPENDS_packagegroup-core-full-cmdline = "\
+ packagegroup-core-full-cmdline-libs \
+ packagegroup-core-full-cmdline-utils \
+ packagegroup-core-full-cmdline-extended \
+ packagegroup-core-full-cmdline-dev-utils \
+ packagegroup-core-full-cmdline-multiuser \
+ packagegroup-core-full-cmdline-initscripts \
+ packagegroup-core-full-cmdline-sys-services \
+ "
+
+RDEPENDS_packagegroup-core-full-cmdline-libs = "\
+ glib-2.0 \
+ "
+
+RDEPENDS_packagegroup-core-full-cmdline-utils = "\
+ bash \
+ acl \
+ attr \
+ bc \
+ coreutils \
+ cpio \
+ e2fsprogs \
+ ed \
+ file \
+ findutils \
+ gawk \
+ gmp \
+ grep \
+ makedevs \
+ mc \
+ mc-fish \
+ mc-helpers \
+ mc-helpers-perl \
+ mc-helpers-python \
+ mktemp \
+ ncurses \
+ net-tools \
+ pax \
+ popt \
+ procps \
+ psmisc \
+ sed \
+ tar \
+ time \
+ util-linux \
+ zlib \
+ "
+
+RDEPENDS_packagegroup-core-full-cmdline-extended = "\
+ iproute2 \
+ iputils \
+ iptables \
+ module-init-tools \
+ openssl \
+ "
+
+RDEPENDS_packagegroup-core-full-cmdline-dev-utils = "\
+ byacc \
+ diffutils \
+ m4 \
+ make \
+ patch \
+ "
+
+VIRTUAL-RUNTIME_initscripts ?= "initscripts"
+VIRTUAL-RUNTIME_init_manager ?= "sysvinit"
+VIRTUAL-RUNTIME_login_manager ?= "busybox"
+VIRTUAL-RUNTIME_syslog ?= "sysklogd"
+RDEPENDS_packagegroup-core-full-cmdline-initscripts = "\
+ ${VIRTUAL-RUNTIME_initscripts} \
+ ${VIRTUAL-RUNTIME_init_manager} \
+ ethtool \
+ ${VIRTUAL-RUNTIME_login_manager} \
+ ${VIRTUAL-RUNTIME_syslog} \
+ "
+
+RDEPENDS_packagegroup-core-full-cmdline-multiuser = "\
+ cracklib \
+ gzip \
+ ${@base_contains('DISTRO_FEATURES', 'pam', 'libuser', '', d)} \
+ shadow \
+ sudo \
+ "
+
+RDEPENDS_packagegroup-core-full-cmdline-sys-services = "\
+ at \
+ bzip2 \
+ cronie \
+ dbus \
+ dbus-glib \
+ python-dbus \
+ elfutils \
+ gzip \
+ less \
+ libcap \
+ libevent \
+ lighttpd \
+ logrotate \
+ nfs-utils \
+ pciutils \
+ libpcre \
+ rpcbind \
+ sysfsutils \
+ tcp-wrappers \
+ tzdata \
+ "
+