aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorChong Lu <Chong.Lu@windriver.com>2014-03-07 09:27:22 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-11 08:07:36 -0700
commit14cc60db64975ad7cb8ae7d50e0233e9d59713df (patch)
treeb5f9772702cafab27534b61867dd13fdb054e925 /meta/recipes-extended
parentf707b6d81d2548e1bc8effdf267d1e40cc2cb806 (diff)
downloadopenembedded-core-contrib-14cc60db64975ad7cb8ae7d50e0233e9d59713df.tar.gz
diffutils: enable ptest support
Install diffutils test suite and run it as ptest. Signed-off-by: Chong Lu <Chong.Lu@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/diffutils/diffutils-3.3/run-ptest3
-rw-r--r--meta/recipes-extended/diffutils/diffutils_3.3.bb20
2 files changed, 22 insertions, 1 deletions
diff --git a/meta/recipes-extended/diffutils/diffutils-3.3/run-ptest b/meta/recipes-extended/diffutils/diffutils-3.3/run-ptest
new file mode 100644
index 0000000000..695c5e8a7b
--- /dev/null
+++ b/meta/recipes-extended/diffutils/diffutils-3.3/run-ptest
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+make -C tests check-TESTS
diff --git a/meta/recipes-extended/diffutils/diffutils_3.3.bb b/meta/recipes-extended/diffutils/diffutils_3.3.bb
index 7a95c1ab43..a467f20aa4 100644
--- a/meta/recipes-extended/diffutils/diffutils_3.3.bb
+++ b/meta/recipes-extended/diffutils/diffutils_3.3.bb
@@ -3,7 +3,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
require diffutils.inc
-SRC_URI = "${GNU_MIRROR}/diffutils/diffutils-${PV}.tar.xz"
+SRC_URI = "${GNU_MIRROR}/diffutils/diffutils-${PV}.tar.xz \
+ file://run-ptest \
+"
do_configure_prepend () {
# Need to remove gettext macros with weird mix of versions
@@ -14,3 +16,19 @@ do_configure_prepend () {
SRC_URI[md5sum] = "99180208ec2a82ce71f55b0d7389f1b3"
SRC_URI[sha256sum] = "a25e89a8ab65fded1731e4186be1bb25cda967834b6df973599cdcd5abdfc19c"
+
+inherit ptest
+
+do_install_ptest() {
+ t=${D}${PTEST_PATH}
+ install -D ${S}/build-aux/test-driver $t/build-aux/test-driver
+ cp -r ${S}/tests $t/
+ install ${B}/tests/Makefile $t/tests/
+ sed -e 's|^Makefile:|_Makefile:|' \
+ -e 's|bash|sh|' \
+ -e 's|^top_srcdir = \(.*\)|top_srcdir = ..\/|' \
+ -e 's|^srcdir = \(.*\)|srcdir = .|' \
+ -e 's|"`$(built_programs)`"|diff|' \
+ -e 's|gawk|awk|g' \
+ -i $t/tests/Makefile
+}