aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorJianchuan Wang <jianchuan.wang@windriver.com>2014-10-17 09:51:45 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-10-24 17:31:57 +0100
commitce0a999efe5c9bfd4780bd2b7c24e99f580474c0 (patch)
tree424893e2f09226bdbd984ac0ed35702cdbd541cc /meta/recipes-extended
parent83be6e94f35b44baa6c363c9518f85e7670246f3 (diff)
downloadopenembedded-core-contrib-ce0a999efe5c9bfd4780bd2b7c24e99f580474c0.tar.gz
libaio: fix for mips64
Add mips64 support in the libaio.h - add macro PADDED/PADDEDptr/PADDEDul in the mips64 for structure iocb to be matched userland with kernel Signed-off-by: Jianchuan Wang <jianchuan.wang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/libaio/libaio/libaio_fix_for_mips64.patch42
-rw-r--r--meta/recipes-extended/libaio/libaio_0.3.109.bb1
2 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-extended/libaio/libaio/libaio_fix_for_mips64.patch b/meta/recipes-extended/libaio/libaio/libaio_fix_for_mips64.patch
new file mode 100644
index 0000000000..0ef9f147be
--- /dev/null
+++ b/meta/recipes-extended/libaio/libaio/libaio_fix_for_mips64.patch
@@ -0,0 +1,42 @@
+From 62fd97fbc5c53835baa18f210fca593fc8b5c636 Mon Sep 17 00:00:00 2001
+From: Jianchuan Wang <jianchuan.wang@windriver.com>
+Date: Wed, 15 Oct 2014 07:04:02 +0800
+Subject: [PATCH] libaio: fix for mips64
+
+Add mips64 support in the libaio.h
+ - add macro PADDED/PADDEDptr/PADDEDul in the mips64 for structure iocb
+ to be matched userland with kernel
+
+Upstream-Status: Backport
+
+Signed-off-by: Jianchuan Wang <jianchuan.wang@windriver.com>
+---
+ src/libaio.h | 12 ++++++++++++
+ 1 file changed, 12 insertions(+)
+
+diff --git a/src/libaio.h b/src/libaio.h
+index ff99188..64ea8f3 100644
+--- a/src/libaio.h
++++ b/src/libaio.h
+@@ -95,6 +95,18 @@ typedef enum io_iocb_cmd {
+ #define PADDED(x, y) unsigned y; x
+ #define PADDEDptr(x, y) unsigned y; x
+ #define PADDEDul(x, y) unsigned y; unsigned long x
++#elif defined(__mips64)
++# if defined (__MIPSEB__) /* big endian, 64 bits */
++#define PADDED(x, y) unsigned y; x
++#define PADDEDptr(x,y) x
++#define PADDEDul(x, y) unsigned long x
++# elif defined(__MIPSEL__) /* little endian, 64 bits */
++#define PADDED(x, y) x, y
++#define PADDEDptr(x, y) x
++#define PADDEDul(x, y) unsigned long x
++# else
++# error "mips64: neither mipseb nor mipsel?"
++# endif
+ #elif defined(__mips__)
+ # if defined (__MIPSEB__) /* big endian, 32 bits */
+ #define PADDED(x, y) unsigned y; x
+--
+1.8.2.1
+
diff --git a/meta/recipes-extended/libaio/libaio_0.3.109.bb b/meta/recipes-extended/libaio/libaio_0.3.109.bb
index 978f5f5fb5..0483c711b9 100644
--- a/meta/recipes-extended/libaio/libaio_0.3.109.bb
+++ b/meta/recipes-extended/libaio/libaio_0.3.109.bb
@@ -15,6 +15,7 @@ SRC_URI = "${DEBIAN_MIRROR}/main/liba/libaio/libaio_${PV}.orig.tar.gz \
file://libaio-generic.patch \
file://libaio-aarch64.patch \
file://libaio_fix_for_mips_syscalls.patch \
+ file://libaio_fix_for_mips64.patch \
"
SRC_URI[md5sum] = "435a5b16ca6198eaf01155263d855756"